[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] FreeBSD PVHVM call for testing

Hash: SHA1

On 06/22/13 07:26, Roger Pau Monnà wrote:
> On 21/06/13 19:55, Miguel Clara wrote:
>> Roger Pau Monnà <roger.pau <at> citrix.com> writes:
>>> Hello,
>>> I've pushed a new branch, pvhvm_v10 that contains a PV IPI 
>>> implementation for both amd64 and i386. I've also updated the
>>> wiki to point to the pvhvm_v10 branch:
>>> http://xenbits.xen.org/gitweb/?p=people/royger/
>> freebsd.git;a=shortlog;h=refs/heads/pvhvm_v10
>>> I've updated my tree to latest HEAD, so now branch pvhvm_v10 is
>>> on top of this commit:
>>> commit b44da0fb82647f2cfb06f65a6695c7e36c98828c Author: gber
>>> <gber <at> FreeBSD.org> Date:   Thu May 23 12:24:46 2013 +0000
>>> Rework and organize pmap_enter_locked() function.
>>> pmap_enter_locked() implementation was very ambiguous and
>>> confusing. Rearrange it so that each part of the mapping
>>> creation is separated. Avoid walking through the redundant
>>> conditions. Extract vector_page specific PTE setup from normal
>>> PTE setting.
>>> Submitted by:   Zbigniew Bodek <zbb <at> semihalf.com> 
>>> Sponsored by:   The FreeBSD Foundation, Semihalf
>>> Thanks for the testing, Roger.
>> Have you (or anyone) done some testing under NetBSD Dom0? I guess
>> its not related, but I'm getting a panic when using SSH.
>> I was able to compile and install the kernel, and booted fine
>> (just needed to adapt fstab, other than that no issues).
>> I've done some tests with ping, ftp, wget, but when I tried SSH
>> (both to the vm and from the vm, I got a panic)
>> ===== PANIC ==== xn_txeof: WARNING: response is -1! debug1:
>> SSH2_MSGxn_txeof: WARNING: response is -1! _KEXINIT receivepanic:
>> mbuf already on the free list, but we're trying to free it
>> again! cpuid = 0 KDB: enter: panic [ thread pid 12 tid 100039 ] 
>> Stopped at      kdb_enter+0x3e: movq    $0,kdb_why db> bt Tracing
>> pid 12 tid 100039 td 0xfffffe0008101000 kdb_enter() at
>> kdb_enter+0x3e/frame 0xffffff8095021940 vpanic() at
>> vpanic+0x146/frame 0xffffff8095021980 kassert_panic() at
>> kassert_panic+0x136/frame 0xffffff80950219f0 xn_txeof() at
>> xn_txeof+0x99/frame 0xffffff8095021a40 xn_intr() at
>> xn_intr+0x59/frame 0xffffff8095021b30 
>> intr_event_execute_handlers() at
>> intr_event_execute_handlers+0x90/frame 0xffffff8095021b70 
>> ithread_loop() at ithread_loop+0x148/frame 0xffffff8095021bb0 
>> fork_exit() at fork_exit+0x84/frame 0xffffff8095021bf0 
>> fork_trampoline() at fork_trampoline+0xe/frame
>> 0xffffff8095021bf0 --- trap 0, rip = 0, rsp = 0xffffff8095021cb0,
>> rbp = 0 --- db>
>> == PANIC ===
>> I've tried with pvhvm_v10 first, and now with pvhvm_v17, but give
>> me the panic!
> Just to make things clear, this is when using a FreeBSD PVHVM DomU
> with a NetBSD Dom0 right? and the crash happens in the FreeBSD
> DomU?
> Could you try to run a FreeBSD HVM (HEAD) guest without my patches
> and see if it also crashes? (just to know if this is a regression
> introduced in my series or a bug that was already there).
> Roger.

Yes its FreeBSD PVHVM DomU "under" NetBSD 6.1 Dom0!

Do you think that the fact that this is a NetBSD dom0 might be related?

I will try without the patches and see what I get!

In the mean time I also noticed that trying to "fetch" some URL (ex:
give Authorization failed... I've tried a few others, same problem!

So its clearly related to the network driver!

I will try without you're patches has suggested and post my results!

Version: GnuPG v2.0.20 (FreeBSD)


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.