[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Booting Xen on Mac Mini

Hi guys,

If it's any help -

We are successfully running XenServer 6 on a pair of Mac Minis.

Being as XenServer is essentially a pre-packaged up version of CentOS 5 with a Xen HV etc, what you guys are doing should be possible with the right config.

This is the kernel version:
Linux vh04 #1 SMP Tue Jan 17 15:14:24 EST 2012 i686 i686 i386 GNU/Linux

If you're interested in trying XenServer (or XCP) on your Mac Minis, I jotted down these helpful notes on our wiki:

  • Reference: Single boot from a Mac Mini
  • Hold down the left Alt key to get the Mac boot menu
  • Boot from the XenServer CD and install like normal, you can use the whole hard drive like normal as well
  • Boot from the Refit CD and choose the 2nd option (something about partition) to synchronize your GPT/MBR
  • Boot from a Apple OS X CD or use the Internet Recovery option
  • Launch a terminal window from the installer
  • Run "bless --device /dev/disk0s1 --setBoot --legacy --verbose"
  • Reboot


On Thu, Jun 13, 2013 at 7:47 AM, Alexis de BRUYN <alexis.mailinglist@xxxxxxxxxxx> wrote:
Hi Aaron,

I have the same issue actually. Did you succeed to boot and run Xen with
your Mac-Mini ? If yes, how did you do and Which distro do you use ?
Thanks for your help.

Best regards,

Aaron Dewell <aaron.dewell <at> gmail.com> writes:

> Hi all,
> I've been running into some troubles getting the hypervisor to load on a
Mac Mini (2012).  I've tried (mostly
> out of boredom): Debian Wheezy, Ubuntu 12.10 and 13.04 (amd64+mac).  It's
currently on the last one, which
> was also the most pain-free install on the system.
> However, when I install Xen (from packages), then try to boot it from
GRUB2 (which works otherwise), it
> fails.  The last message I see (apart from "loading" ones defined in
grub.cfg) is "WARNING: No console will
> be available to OS".  I wouldn't care about the console (the Mini is in a
rack, headless), but it also never
> requests a DHCP address as it does without the HV.  I assume that apart
from the console issue, nothing else
> is successful either, though if it was partially working, I'd have no
due to the lack of a console.
> My next step was going to be to get the source, compile it and try
(since an EFI executable does not
> appear to come with any of the Ubuntu packages).  Binaries are easier, so
that's what I tried first, but that
> appears to be the next step unless someone has another suggestion?
> Thanks!  I appreciate any and all advice,
> Aaron

Alexis de BRUYN

Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.