|
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: BUG kernel 6.12.19 defautl_swiotlb_limit() returns wrong value for CONFIG_SWIOTLB_DYNAMIC=y effects atm only under XEN dom0
On 18.09.2026 08:37, James Dingwall wrote: > I've been having a problem with a Dell HBA330 SCSI controller (mpt3sas) > when booting under Xen and CONFIG_SWIOTLB_DYNAMIC=y is set. I had a > similar issue with a megaraid_sas card that I previously posted about: > > https://lkml.iu.edu/hypermail/linux/kernel/2407.3/08254.html > > In that case we rebuilt the kernel with CONFIG_SWIOTLB_DYNAMIC=n. > While investigating the current problem I came across a patch that was > posted on the xen-devel list: > > https://protect2.fireeye.com/v1/url?k=202f9c3b-7fb4525f-202e1774-000babda0201-d2724d878716e4ba&q=1&e=538195f2-f8bd-499e-8576-5e3d7c8ebca6&u=https%3A%2F%2Flists.xen.org%2Farchives%2Fhtml%2Fxen-devel%2F2025-05%2Fmsg00991.html > > I have applied that to the Ubuntu 7.0.0-31 kernel sources which has > resolved the controller initialisation error I was encountering and the > system now boots as expected. > > [ 3.921136] mpt3sas_cm0: no suitable DMA mask for 0000:03:00.0 > [ 3.921275] mpt3sas_cm0: failure at > drivers/scsi/mpt3sas/mpt3sas_scsih.c:13610/_scsih_probe()! > > I've included the patch below, I don't have the author's real address > for the s-o-b. I'm able to test alternative fixes if there are any > issues with this one. https://lore.kernel.org/xen-devel/93625976-e8af-4c39-90fb-45c926d420fd@xxxxxxxxxx/ Andreas: could You send Your fix with a bit more elaborated description and to the proper recipients (hint: use scripts/get_maintainer.pl tool), so it can be reviewed and potentially applied? Best regards -- Marek Szyprowski, PhD Samsung R&D Institute Poland
|
![]() |
Lists.xenproject.org is hosted with RackSpace, monitoring our |