[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH 00/22] i8259: improve qdev PIC modelling (and misc fixes)


  • To: pbonzini@xxxxxxxxxx, richard.henderson@xxxxxxxxxx, mst@xxxxxxxxxx, sstabellini@xxxxxxxxxx, anthony@xxxxxxxxxxxxxx, edgar.iglesias@xxxxxxxxx, qemu-devel@xxxxxxxxxx, xen-devel@xxxxxxxxxxxxxxxxxxxx
  • From: Mark Cave-Ayland <mark.caveayland@xxxxxxxxxxx>
  • Date: Wed, 16 Sep 2026 11:43:28 +0100
  • Arc-authentication-results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=nutanix.com; dmarc=pass action=none header.from=nutanix.com; dkim=pass header.d=nutanix.com; arc=none
  • Arc-message-signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=hLA8q5A8LzbaduFj9D065CiadtRTYoD6VhJ5ec0zV+Q=; b=qiHsNw0cGyK5t+WLu3/ROwQksnqrfZnSwM0eu15NnNBFa7iK3PP4tQCVPUyXdxNCP7LYp0Icl3W1QJte0yXK7rl0PcVwyi+15hgBCUsdBHV/O2qQhget57JUn/KGFUF9KfcfW/JkdDf1+3mRJPT7FRgueYBbXPBHGx161qLOLjJl4zmsJ/5ffeAEDsg2fWI9RW++cNt8740VgTqCxVJ0/kmim6YwEChvsq/51SIhSaZ0sWxL1b2OxvjUTN7McRsTrypS3OCEEoa7h9+PSQLAYNciPb0RoKBoi3AK22TIKTsCDk56jVuoZi/GsaKhmKFV24dXYj04wR9NW91y8l5J7g==
  • Arc-seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=yJ/J9jdNcGtBRFWO7H1IhFI1788p0e2neYO8VylFKcD0BWVXEYC64YLDAM9MnbwBuGH1DU6xIu109rQvba//MepnKdO/UjGFv+FIlh6r9l6qVTQlDKvYnj11+OvhLvto9nyArNxsZnm/nVVCVOb30JuZbt51vGjIdxgeJAVBhJKwz/v+XHwEq6kE5dIFusQnCc3JJ4w+hCVIZ1istI7E78RzQfzdlf5vlEwukZDPZ0hAo+PPGFjqOnqCEJPYr2QklvnioRh+1t9Yx8xVh2s91egPpxbrxTlJ8qFH5BZjrdbLk8XnhrsMonfmT4pz8ACEr6dpv1AFnmopKWxrhjDCtQ==
  • Authentication-results: eu.smtp.expurgate.cloud; dkim=pass header.s=proofpoint20171006 header.d=nutanix.com header.i="@nutanix.com" header.h="Content-Transfer-Encoding:Content-Type:Date:From:Message-ID:MIME-Version:Subject:To"; dkim=pass header.s=selector1 header.d=nutanix.com header.i="@nutanix.com" header.h="From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-SenderADCheck"
  • Delivery-date: Wed, 16 Sep 2026 10:45:00 +0000
  • List-id: Xen developer discussion <xen-devel.lists.xenproject.org>

This series attempts to improve the modelling of legacy x86 PICs within
QEMU. The initial aim was to have a qdev device with one output gpio, and
16 input gpios representing the legacy IRQ lines, however as I went about
trying to model this, I found a number of other inconsistencies/bugs: in
particular there seemed to be some fuzziness around the functionality that
belongs to an individual i8259 chip, and a cascaded i8259 configuration.

For the purposes of this patch an i8259 device is considered to be a single
i8259 chip whilst a PIC device is considered to be either a cascaded i8259
configuration (emulated/KVM) or standalone device (Xen) representing the set
of 16 legacy IRQs and a single output IRQ.

Due to the updated device names, there is currently one visible change in
the HMP monitor output for "info irq" where the isa-i8259 device now appears
as isa-i8259-pic and the kvm-i8259 device appears as kvm-i8259-pic (see
patch 19).

Signed-off-by: Mark Cave-Ayland <mark.caveayland@xxxxxxxxxxx>


Mark Cave-Ayland (22):
  i8259_internal.h: rename PIC_COMMON to I8259_COMMON
  i8259_internal.h: rename TYPE_I8259_COMMON to i8259-common
  i8259_internal.h: rename PICCommonState to I8259CommonState
  i8259_internal.h: rename PICCommonClass to I8259CommonClass
  i8259.c: move parent_realize from PICClass to I8259CommonClass
  kvm/i8259.c: move parent_realize from KVMPICClass to I8259CommonClass
  i8259_common.c: use i8259/i8259_common prefix for functions
  i8259.c: use i8259 prefix for functions
  kvm/i8259.c: use kvm_i8259 prefix for functions
  i8259_common.c: convert to use DEFINE_TYPES() macro
  i8259.c: convert to use DEFINE_TYPES() macro
  kvm/i8259.c: convert to use DEFINE_TYPES() macro
  i8259.c: introduce TYPE_I8259_PIC device
  i8259.c: properly cascade secondary i8259 from primary i8259
  kvm/i8259.c: introduce TYPE_KVM_I8259_PIC device
  xen-hvm.c: rename xen_interrupt_controller_init() to xen_i8259_init()
  xen/xen-hvm.c: introduce TYPE_XEN_I8259_PIC device
  i8259_common.c: remove unused i8259_init_chip() function
  i8259: move InterruptStatsProviderClass get_statistics() from i8259 to
    PIC
  i8259.c: switch isa_pic from I8259CommonState to I8259PICState
  i8259_common.c: remove static irq_count and irq_level variables
  i8259_common.c: add missing 0x prefixes to "info pic" output

 include/hw/intc/i8259.h         |  12 +-
 include/hw/isa/i8259_internal.h |  21 ++-
 include/hw/xen/xen.h            |   2 +-
 hw/i386/kvm/i8259.c             | 167 +++++++++++++----
 hw/i386/pc.c                    |   2 +-
 hw/i386/xen/xen-hvm.c           |  40 +++-
 hw/intc/i8259.c                 | 322 +++++++++++++++++++++-----------
 hw/intc/i8259_common.c          | 171 ++++++++---------
 stubs/xen-hw-stub.c             |   2 +-
 9 files changed, 477 insertions(+), 262 deletions(-)

-- 
2.43.0




 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.