|
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [PATCH v5 1/2] x86/CPU: re-arrange tail of early_cpu_init()
On Wed, Aug 19, 2026 at 01:45:31PM +0200, Jan Beulich wrote: > Some early setup doesn't need re-doing after ucode load. Move the call to > initialize_cpu_data() slightly up and add a conditional return point. > > Signed-off-by: Jan Beulich <jbeulich@xxxxxxxx> Acked-by: Roger Pau Monné <roger@xxxxxxxxxxxxxx> > --- > The parameter being named "verbose" may be a little irritating for this > use, yet renaming would incur extra churn. > > Clearly an alternative would be to split the function. I can't, however, > seem to be able to think of a good name for the part that would be invoked > post-ucode-loading. Maybe early_cpu_reinit(), except that calling that > from early_cpu_init() then still feel somewhat odd. No strong opinion. The code that doesn't need redoing seems so little that splitting this might not (yet?) be necessary. Thanks, Roger.
|
![]() |
Lists.xenproject.org is hosted with RackSpace, monitoring our |