|
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [PATCH] x86/hvm: Use system descriptor type names in hvm_task_switch()
... rather than magic numbers.
No functional change.
Signed-off-by: Andrew Cooper <andrew.cooper3@xxxxxxxxxx>
---
CC: Jan Beulich <jbeulich@xxxxxxxx>
CC: Roger Pau Monné <roger@xxxxxxxxxxxxxx>
CC: Teddy Astie <teddy.astie@xxxxxxxxxx>
---
xen/arch/x86/hvm/hvm.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/xen/arch/x86/hvm/hvm.c b/xen/arch/x86/hvm/hvm.c
index 955fc062a5c7..56bc2857389c 100644
--- a/xen/arch/x86/hvm/hvm.c
+++ b/xen/arch/x86/hvm/hvm.c
@@ -3066,7 +3066,8 @@ void hvm_task_switch(
if ( tr.g )
tr.limit = (tr.limit << 12) | 0xfffu;
- if ( tr.type != ((taskswitch_reason == TSW_iret) ? 0xb : 0x9) )
+ if ( tr.type != (taskswitch_reason == TSW_iret
+ ? SYS_DESC_tss_busy : SYS_DESC_tss_avail) )
{
hvm_inject_hw_exception(
(taskswitch_reason == TSW_iret) ? X86_EXC_TS : X86_EXC_GP,
@@ -3192,7 +3193,7 @@ void hvm_task_switch(
goto out;
}
- tr.type = 0xb; /* busy 32-bit tss */
+ tr.type = SYS_DESC_tss_busy;
hvm_set_segment_register(v, x86_seg_tss, &tr);
v->arch.hvm.guest_cr[0] |= X86_CR0_TS;
--
2.39.5
|
![]() |
Lists.xenproject.org is hosted with RackSpace, monitoring our |