[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH 07/13] mm/vma: rename vma_get_page_prot to vma_flags_to_page_prot
- To: "Lorenzo Stoakes" <ljs@xxxxxxxxxx>, "Andrew Morton" <akpm@xxxxxxxxxxxxxxxxxxxx>
- From: "Zi Yan" <ziy@xxxxxxxxxx>
- Date: Tue, 07 Jul 2026 22:31:20 -0400
- Arc-authentication-results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=nvidia.com; dmarc=pass action=none header.from=nvidia.com; dkim=pass header.d=nvidia.com; arc=none
- Arc-message-signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=ttxfngV3H6lKnDvvUfKS5bkddGHszwBGKHpn0tQr5RE=; b=fW5ZYoDK593YrhoaL/BRgnDrqzx56QLI7hX7jwS8PHqSWS4ZXTp0vIxBIt3+2CWwzeLMlNzKB7Tjk/N/UhbU85EKfTQY7SX1NwNlUS8NkqAGVnLePBRbxFoqRRDj8wntTR+bZ6oNtASkKtXM3n2DNLg94ysRdMei8tV4o81dv6xGDGx0bRs7m+dHMFFTiyO5kcHHYJJW7gG6je7DXUhK+iTGux39U2wQL8wf0pUrJwX2zFRDDNIkJD6uvKMsWC6VfqLg+G/7Ak7nMZ6Dqbuw/WpjZn/pFDlukEKIe85G3py2Kn0JQO5i+8tmi2nKBnum104bqdq9cOLW1WPAEScz5Q==
- Arc-seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=SonGZCQTfL4B86QLMg28+HjnMm4XXarTlNQe/Bl1VayW0rTNE4KvMGL1vb4/1z68SP5esKqvsDATtGeYj0TSdQqSvEofdIaCNB4RLrof+2OyaAgFY9eAL2CGY1qtGtJOGhFmvfwcr8dsMTgTF5fBfMsPUnejzZzsx705kgVSH3PydNkqdLz7PW3Q/RSjJQ1HmNfz642s9v972prGQI184HXl45fjtGGprYteL/T/JXWkwycIHGHgVcLjhNUsXQ+FMUbPl5VoH/7Z503G9UHOPXXpze6qz0uBA7jbSeH9XZPvRlS3c0Gn7FSSXuDq3EkXMOXZ1QoeKSW85dKB1bExhA==
- Authentication-results: eu.smtp.expurgate.cloud; dkim=temperror header.s=selector2 header.d=Nvidia.com header.i="@Nvidia.com"
- Authentication-results: dkim=none (message not signed) header.d=none;dmarc=none action=none header.from=nvidia.com;
- Cc: "Thomas Bogendoerfer" <tsbogend@xxxxxxxxxxxxxxxx>, "Madhavan Srinivasan" <maddy@xxxxxxxxxxxxx>, "Michael Ellerman" <mpe@xxxxxxxxxxxxxx>, "Maarten Lankhorst" <maarten.lankhorst@xxxxxxxxxxxxxxx>, "Maxime Ripard" <mripard@xxxxxxxxxx>, "Thomas Zimmermann" <tzimmermann@xxxxxxx>, "David Airlie" <airlied@xxxxxxxxx>, "Simona Vetter" <simona@xxxxxxxx>, "Lucas Stach" <l.stach@xxxxxxxxxxxxxx>, "Inki Dae" <inki.dae@xxxxxxxxxxx>, "Seung-Woo Kim" <sw0312.kim@xxxxxxxxxxx>, "Kyungmin Park" <kyungmin.park@xxxxxxxxxxx>, "Krzysztof Kozlowski" <krzk@xxxxxxxxxx>, "Peter Griffin" <peter.griffin@xxxxxxxxxx>, "Jani Nikula" <jani.nikula@xxxxxxxxxxxxxxx>, "Joonas Lahtinen" <joonas.lahtinen@xxxxxxxxxxxxxxx>, "Rodrigo Vivi" <rodrigo.vivi@xxxxxxxxx>, "Tvrtko Ursulin" <tursulin@xxxxxxxxxxx>, "Rob Clark" <robin.clark@xxxxxxxxxxxxxxxx>, "Dmitry Baryshkov" <lumag@xxxxxxxxxx>, "Lyude Paul" <lyude@xxxxxxxxxx>, "Danilo Krummrich" <dakr@xxxxxxxxxx>, "Tomi Valkeinen" <tomi.valkeinen@xxxxxxxxxxxxxxxx>, "Sandy Huang" <hjc@xxxxxxxxxxxxxx>, Heiko Stübner <heiko@xxxxxxxxx>, "Andy Yan" <andy.yan@xxxxxxxxxxxxxx>, "Thierry Reding" <thierry.reding@xxxxxxxxxx>, "Mikko Perttunen" <mperttunen@xxxxxxxxxx>, "Jonathan Hunter" <jonathanh@xxxxxxxxxx>, "Gerd Hoffmann" <kraxel@xxxxxxxxxx>, "Dmitry Osipenko" <dmitry.osipenko@xxxxxxxxxxxxx>, "Zack Rusin" <zack.rusin@xxxxxxxxxxxx>, "Matthew Brost" <matthew.brost@xxxxxxxxx>, "Thomas Hellstrom" <thomas.hellstrom@xxxxxxxxxxxxxxx>, "Oleksandr Andrushchenko" <oleksandr_andrushchenko@xxxxxxxx>, "Helge Deller" <deller@xxxxxx>, "Benjamin LaHaise" <bcrl@xxxxxxxxx>, "Alexander Viro" <viro@xxxxxxxxxxxxxxxxxx>, "Christian Brauner" <brauner@xxxxxxxxxx>, "Muchun Song" <muchun.song@xxxxxxxxx>, "Oscar Salvador" <osalvador@xxxxxxx>, "David Hildenbrand" <david@xxxxxxxxxx>, "Baolin Wang" <baolin.wang@xxxxxxxxxxxxxxxxx>, "Liam R . Howlett" <liam@xxxxxxxxxxxxx>, "Nico Pache" <npache@xxxxxxxxxx>, "Ryan Roberts" <ryan.roberts@xxxxxxx>, "Dev Jain" <dev.jain@xxxxxxx>, "Barry Song" <baohua@xxxxxxxxxx>, "Lance Yang" <lance.yang@xxxxxxxxx>, "Hugh Dickins" <hughd@xxxxxxxxxx>, "Vlastimil Babka" <vbabka@xxxxxxxxxx>, "Mike Rapoport" <rppt@xxxxxxxxxx>, "Suren Baghdasaryan" <surenb@xxxxxxxxxx>, "Michal Hocko" <mhocko@xxxxxxxx>, "Jann Horn" <jannh@xxxxxxxxxx>, "Pedro Falcato" <pfalcato@xxxxxxx>, "Kees Cook" <kees@xxxxxxxxxx>, "Jaroslav Kysela" <perex@xxxxxxxx>, "Takashi Iwai" <tiwai@xxxxxxxx>, <linux-mips@xxxxxxxxxxxxxxx>, <linux-kernel@xxxxxxxxxxxxxxx>, <linuxppc-dev@xxxxxxxxxxxxxxxx>, <dri-devel@xxxxxxxxxxxxxxxxxxxxx>, <etnaviv@xxxxxxxxxxxxxxxxxxxxx>, <linux-arm-kernel@xxxxxxxxxxxxxxxxxxx>, <linux-samsung-soc@xxxxxxxxxxxxxxx>, <intel-gfx@xxxxxxxxxxxxxxxxxxxxx>, <linux-arm-msm@xxxxxxxxxxxxxxx>, <freedreno@xxxxxxxxxxxxxxxxxxxxx>, <nouveau@xxxxxxxxxxxxxxxxxxxxx>, <linux-rockchip@xxxxxxxxxxxxxxxxxxx>, <linux-tegra@xxxxxxxxxxxxxxx>, <virtualization@xxxxxxxxxxxxxxx>, <intel-xe@xxxxxxxxxxxxxxxxxxxxx>, <xen-devel@xxxxxxxxxxxxxxxxxxxx>, <linux-fbdev@xxxxxxxxxxxxxxx>, <linux-aio@xxxxxxxxx>, <linux-fsdevel@xxxxxxxxxxxxxxx>, <linux-mm@xxxxxxxxx>, <linux-sound@xxxxxxxxxxxxxxx>
- Delivery-date: Wed, 08 Jul 2026 02:31:39 +0000
- List-id: Xen developer discussion <xen-devel.lists.xenproject.org>
On Mon Jun 29, 2026 at 3:25 PM EDT, Lorenzo Stoakes wrote:
> Having vma_get_page_prot() refer to VMA flags and vma_set_page_prot() refer
> to a VMA is confusing.
>
> Rename vma_get_page_prot() to vma_flags_to_page_prot() to resolve this
> confusion.
>
> No functional change intended.
>
> Signed-off-by: Lorenzo Stoakes <ljs@xxxxxxxxxx>
> ---
> include/linux/mm.h | 4 ++--
> mm/vma.c | 2 +-
> mm/vma.h | 2 +-
> tools/testing/vma/include/dup.h | 2 +-
> 4 files changed, 5 insertions(+), 5 deletions(-)
>
Makes sense.
Reviewed-by: Zi Yan <ziy@xxxxxxxxxx>
--
Best Regards,
Yan, Zi
|