[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH 10/13] mm/vma: convert miscellaneous uses of VMA flags in core mm
- To: ljs@xxxxxxxxxx
- From: Lance Yang <lance.yang@xxxxxxxxx>
- Date: Thu, 2 Jul 2026 21:12:33 +0800
- Authentication-results: eu.smtp.expurgate.cloud; dkim=pass header.s=key1 header.d=linux.dev header.i="@linux.dev" header.h="From:Subject:Date:Message-Id:To:Cc:MIME-Version:Content-Type:Content-Transfer-Encoding:In-Reply-To:References"
- Cc: akpm@xxxxxxxxxxxxxxxxxxxx, tsbogend@xxxxxxxxxxxxxxxx, maddy@xxxxxxxxxxxxx, mpe@xxxxxxxxxxxxxx, maarten.lankhorst@xxxxxxxxxxxxxxx, mripard@xxxxxxxxxx, tzimmermann@xxxxxxx, airlied@xxxxxxxxx, simona@xxxxxxxx, l.stach@xxxxxxxxxxxxxx, inki.dae@xxxxxxxxxxx, sw0312.kim@xxxxxxxxxxx, kyungmin.park@xxxxxxxxxxx, krzk@xxxxxxxxxx, peter.griffin@xxxxxxxxxx, jani.nikula@xxxxxxxxxxxxxxx, joonas.lahtinen@xxxxxxxxxxxxxxx, rodrigo.vivi@xxxxxxxxx, tursulin@xxxxxxxxxxx, robin.clark@xxxxxxxxxxxxxxxx, lumag@xxxxxxxxxx, lyude@xxxxxxxxxx, dakr@xxxxxxxxxx, tomi.valkeinen@xxxxxxxxxxxxxxxx, hjc@xxxxxxxxxxxxxx, heiko@xxxxxxxxx, andy.yan@xxxxxxxxxxxxxx, thierry.reding@xxxxxxxxxx, mperttunen@xxxxxxxxxx, jonathanh@xxxxxxxxxx, kraxel@xxxxxxxxxx, dmitry.osipenko@xxxxxxxxxxxxx, zack.rusin@xxxxxxxxxxxx, matthew.brost@xxxxxxxxx, thomas.hellstrom@xxxxxxxxxxxxxxx, oleksandr_andrushchenko@xxxxxxxx, deller@xxxxxx, bcrl@xxxxxxxxx, viro@xxxxxxxxxxxxxxxxxx, brauner@xxxxxxxxxx, muchun.song@xxxxxxxxx, osalvador@xxxxxxx, david@xxxxxxxxxx, ziy@xxxxxxxxxx, baolin.wang@xxxxxxxxxxxxxxxxx, liam@xxxxxxxxxxxxx, npache@xxxxxxxxxx, ryan.roberts@xxxxxxx, dev.jain@xxxxxxx, baohua@xxxxxxxxxx, lance.yang@xxxxxxxxx, hughd@xxxxxxxxxx, vbabka@xxxxxxxxxx, rppt@xxxxxxxxxx, surenb@xxxxxxxxxx, mhocko@xxxxxxxx, jannh@xxxxxxxxxx, pfalcato@xxxxxxx, kees@xxxxxxxxxx, perex@xxxxxxxx, tiwai@xxxxxxxx, linux-mips@xxxxxxxxxxxxxxx, linux-kernel@xxxxxxxxxxxxxxx, linuxppc-dev@xxxxxxxxxxxxxxxx, dri-devel@xxxxxxxxxxxxxxxxxxxxx, etnaviv@xxxxxxxxxxxxxxxxxxxxx, linux-arm-kernel@xxxxxxxxxxxxxxxxxxx, linux-samsung-soc@xxxxxxxxxxxxxxx, intel-gfx@xxxxxxxxxxxxxxxxxxxxx, linux-arm-msm@xxxxxxxxxxxxxxx, freedreno@xxxxxxxxxxxxxxxxxxxxx, nouveau@xxxxxxxxxxxxxxxxxxxxx, linux-rockchip@xxxxxxxxxxxxxxxxxxx, linux-tegra@xxxxxxxxxxxxxxx, virtualization@xxxxxxxxxxxxxxx, intel-xe@xxxxxxxxxxxxxxxxxxxxx, xen-devel@xxxxxxxxxxxxxxxxxxxx, linux-fbdev@xxxxxxxxxxxxxxx, linux-aio@xxxxxxxxx, linux-fsdevel@xxxxxxxxxxxxxxx, linux-mm@xxxxxxxxx, linux-sound@xxxxxxxxxxxxxxx
- Delivery-date: Thu, 02 Jul 2026 13:13:26 +0000
- List-id: Xen developer discussion <xen-devel.lists.xenproject.org>
On Mon, Jun 29, 2026 at 08:25:33PM +0100, Lorenzo Stoakes wrote:
>Update various uses of legacy flags in vma.c and mmap.c to the new
>vma_flags_t type, updating comments alongside them to be consistent.
>
>Also update __install_special_mapping() to rearrange things slightly to
>accommodate the changes.
>
>Signed-off-by: Lorenzo Stoakes <ljs@xxxxxxxxxx>
>---
[...]
>diff --git a/mm/vma.c b/mm/vma.c
>index b81c05e67a61..ab2ef0f04420 100644
>--- a/mm/vma.c
>+++ b/mm/vma.c
>@@ -3417,23 +3417,27 @@ struct vm_area_struct *__install_special_mapping(
> vm_flags_t vm_flags, void *priv,
> const struct vm_operations_struct *ops)
> {
>- int ret;
>+ vma_flags_t vma_flags = legacy_to_vma_flags(vm_flags);
> struct vm_area_struct *vma;
>+ int ret;
>
> vma = vm_area_alloc(mm);
>- if (unlikely(vma == NULL))
>+ if (unlikely(!vma))
> return ERR_PTR(-ENOMEM);
>
>- vma_set_range(vma, addr, addr + len, 0);
>- vm_flags |= vma_flags_to_legacy(mm->def_vma_flags) | VM_DONTEXPAND;
>+ vma_flags_set_mask(&vma_flags, mm->def_vma_flags);
>+ vma_flags_set(&vma_flags, VMA_DONTEXPAND_BIT);
> if (pgtable_supports_soft_dirty())
>- vm_flags |= VM_SOFTDIRTY;
>- vm_flags_init(vma, vm_flags & ~VM_LOCKED_MASK);
>+ vma_flags_set(&vma_flags, VMA_SOFTDIRTY_BIT);
>+ vma_flags_clear_mask(&vma_flags, VMA_LOCKED_MASK);
>+ vma->flags = vma_flags;
Maybe worth a vma_flags_init() helper here to mirror vm_flags_init()?
With this open-coded, we lose the soft-dirty WARN_ON_ONCE sanity check.
Might be nicer to keep that check in one place ;)
[...]
|