[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [PATCH v3 00/14] MSR code cleanup part one
On Fri, Apr 25, 2025 at 01:34:23AM -0700, Xin Li (Intel) wrote: > This patch set is the first part of the patch set: > > MSR refactor with new MSR instructions support > > @ > https://lore.kernel.org/lkml/20250422082216.1954310-1-xin@xxxxxxxxx/T/#m5a34be7d4ed55f0baca965cb65452a08e9ad7c8a > > > It's getting *WAY* too big, and whether to zap the pv_ops MSR APIs is > still under argument. Dave Hansen suggested to focus on rename stuff > first, most of which he acked. > > Jürgen Groß also gave his RBs to most of the Xen MSR cleanup patches. > > So here comes the first MSR cleanup patch set with version 3. > > > This patch series is based on: > > git://git.kernel.org/pub/scm/linux/kernel/git/tip/tip.git x86/msr > > > Xin Li (Intel) (14): > x86/msr: Move rdtsc{,_ordered}() to <asm/tsc.h> > x86/msr: Remove rdpmc() > x86/msr: Rename rdpmcl() to rdpmc() > x86/msr: Convert the rdpmc() macro into an always inline function > x86/msr: Return u64 consistently in Xen PMC read functions > x86/msr: Convert __wrmsr() uses to native_wrmsr{,q}() uses > x86/msr: Add the native_rdmsrq() helper > x86/msr: Convert __rdmsr() uses to native_rdmsrq() uses > x86/xen/msr: Remove calling native_{read,write}_msr{,_safe}() in > pmu_msr_{read,write}() > x86/xen/msr: Remove pmu_msr_{read,write}() > x86/xen/msr: Remove the error pointer argument from set_seg() > x86/pvops/msr: refactor pv_cpu_ops.write_msr{,_safe}() > x86/msr: Replace wrmsr(msr, low, 0) with wrmsrq(msr, low) > x86/msr: Change the function type of native_read_msr_safe() These look ok. Acked-by: Peter Zijlstra (Intel) <peterz@xxxxxxxxxxxxx>
|
![]() |
Lists.xenproject.org is hosted with RackSpace, monitoring our |