[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [PATCH v5 00/12] Hyperlaunch device tree for dom0
On Thu, Apr 24, 2025 at 05:10:10PM +0100, Alejandro Vallejo wrote: > Hi, > > v4: https://lore.kernel.org/xen-devel/20250417124844.11143-1-agarciav@xxxxxxx/ > v3: https://lore.kernel.org/xen-devel/20250408160802.49870-1-agarciav@xxxxxxx/ > v2: > https://lore.kernel.org/xen-devel/20241226165740.29812-1-dpsmith@xxxxxxxxxxxxxxxxxxxx/ > v1: > https://lore.kernel.org/xen-devel/20241123182044.30687-1-dpsmith@xxxxxxxxxxxxxxxxxxxx/ > > ========= Original cover letter: > > The Hyperlaunch device tree for dom0 series is the second split out for the > introduction of the Hyperlaunch domain builder logic. These changes focus on > introducing the ability to express a domain configuration that is then used to > populate the struct boot_domain structure for dom0. This ability to express a > domain configuration provides the next step towards a general domain builder. > > The splitting of Hyperlaunch into a set of series are twofold, to reduce the > effort in reviewing a much larger series, and to reduce the effort in handling > the knock-on effects to the construction logic from requested review changes. > > > > Alejandro Vallejo (1): > x86/hyperlaunch: Add helpers to locate multiboot modules > > Daniel P. Smith (11): > kconfig: introduce domain builder config options > common/hyperlaunch: introduce the domain builder > x86/hyperlaunch: initial support for hyperlaunch device tree > x86/hyperlaunch: locate dom0 kernel with hyperlaunch > x86/hyperlaunch: obtain cmdline from device tree > x86/hyperlaunch: locate dom0 initrd with hyperlaunch > x86/hyperlaunch: add domain id parsing to domain config > x86/hyperlaunch: specify dom0 mode with device tree > x86/hyperlaunch: add memory parsing to domain config > x86/hyperlaunch: add max vcpu parsing of hyperlaunch device tree > x86/hyperlaunch: add capabilities to boot domain One general comment w.r.t. naming notation in: xen/common/domain-builder/fdt.c xen/common/domain-builder/fdt.h Sorry, overlooked that earlier. What do you think about using fdt_<something> notation for all functions in fdt.{c,h}? For example: s/detect_fdt_kind/fdt_detect_hyperlauch_node/ s/find_hyperlaunch_node/fdt_find_hyperlauch_node/ s/walk_hyperlaunch_fdt/fdt_walk_hyperlauch_node/ s/process_domain_node/fdt_process_hyperlauch_node/ Other than that: Reviewed-by: Denis Mukhin <dmukhin@xxxxxxxx> for the series. > > xen/arch/x86/dom0_build.c | 11 + > xen/arch/x86/include/asm/boot-domain.h | 14 + > xen/arch/x86/include/asm/bootinfo.h | 10 +- > xen/arch/x86/setup.c | 64 +++- > xen/common/Kconfig | 2 + > xen/common/Makefile | 1 + > xen/common/domain-builder/Kconfig | 15 + > xen/common/domain-builder/Makefile | 2 + > xen/common/domain-builder/core.c | 86 +++++ > xen/common/domain-builder/fdt.c | 512 +++++++++++++++++++++++++ > xen/common/domain-builder/fdt.h | 40 ++ > xen/include/xen/domain-builder.h | 37 ++ > xen/include/xen/libfdt/libfdt-xen.h | 23 ++ > 13 files changed, 800 insertions(+), 17 deletions(-) > create mode 100644 xen/common/domain-builder/Kconfig > create mode 100644 xen/common/domain-builder/Makefile > create mode 100644 xen/common/domain-builder/core.c > create mode 100644 xen/common/domain-builder/fdt.c > create mode 100644 xen/common/domain-builder/fdt.h > create mode 100644 xen/include/xen/domain-builder.h > > -- > 2.43.0 > >
|
![]() |
Lists.xenproject.org is hosted with RackSpace, monitoring our |