[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [PATCH v2 1/3] x86/apic: remove delivery and destination mode fields from drivers
On 06.03.2025 16:54, Roger Pau Monné wrote: > On Thu, Mar 06, 2025 at 04:33:37PM +0100, Jan Beulich wrote: >> On 06.03.2025 15:57, Roger Pau Monne wrote: >>> --- a/xen/arch/x86/genapic/bigsmp.c >>> +++ b/xen/arch/x86/genapic/bigsmp.c >>> @@ -46,8 +46,6 @@ static int __init cf_check probe_bigsmp(void) >>> >>> const struct genapic __initconst_cf_clobber apic_bigsmp = { >>> APIC_INIT("bigsmp", probe_bigsmp), >>> - .int_delivery_mode = dest_Fixed, >>> - .int_dest_mode = 0, /* physical delivery */ >>> .init_apic_ldr = init_apic_ldr_phys, >>> .vector_allocation_cpumask = vector_allocation_cpumask_phys, >>> .cpu_mask_to_apicid = cpu_mask_to_apicid_phys, >>> --- a/xen/arch/x86/genapic/default.c >>> +++ b/xen/arch/x86/genapic/default.c >>> @@ -16,8 +16,6 @@ >>> /* should be called last. */ >>> const struct genapic __initconst_cf_clobber apic_default = { >>> APIC_INIT("default", NULL), >>> - .int_delivery_mode = dest_Fixed, >>> - .int_dest_mode = 0, /* physical delivery */ >>> .init_apic_ldr = init_apic_ldr_flat, >>> .vector_allocation_cpumask = vector_allocation_cpumask_phys, >>> .cpu_mask_to_apicid = cpu_mask_to_apicid_phys, >>> --- a/xen/arch/x86/genapic/x2apic.c >>> +++ b/xen/arch/x86/genapic/x2apic.c >>> @@ -140,8 +140,6 @@ static void cf_check send_IPI_mask_x2apic_cluster( >>> >>> static const struct genapic __initconst_cf_clobber apic_x2apic_phys = { >>> APIC_INIT("x2apic_phys", NULL), >>> - .int_delivery_mode = dest_Fixed, >>> - .int_dest_mode = 0 /* physical delivery */, >>> .init_apic_ldr = init_apic_ldr_phys, >>> .vector_allocation_cpumask = vector_allocation_cpumask_phys, >>> .cpu_mask_to_apicid = cpu_mask_to_apicid_phys, >>> @@ -163,8 +161,6 @@ static const struct genapic __initconst_cf_clobber >>> apic_x2apic_mixed = { >>> * The following fields are exclusively used by external interrupts and >>> * hence are set to use Physical destination mode handlers. >>> */ >>> - .int_delivery_mode = dest_Fixed, >>> - .int_dest_mode = 0 /* physical delivery */, >>> .vector_allocation_cpumask = vector_allocation_cpumask_phys, >>> .cpu_mask_to_apicid = cpu_mask_to_apicid_phys, >> >> Like we had it everywhere above, ... >> >>> --- a/xen/arch/x86/io_apic.c >>> +++ b/xen/arch/x86/io_apic.c >>> @@ -1080,8 +1080,8 @@ static void __init setup_IO_APIC_irqs(void) >>> */ >>> memset(&entry,0,sizeof(entry)); >>> >>> - entry.delivery_mode = INT_DELIVERY_MODE; >>> - entry.dest_mode = INT_DEST_MODE; >>> + entry.delivery_mode = dest_Fixed; >>> + entry.dest_mode = 0; >> >> ... here and below these zeros would better gain a comment, or be expressed >> as e.g. (untested) MASK_EXTR(APIC_DEST_PHYSICAL, APIC_DEST_MASK). > > I've started adding those comments, but then I got the impression they > where a bit redundant, many of the setting of the fields didn't have a > matching comment. I was even tempted to just not setting the field at > all, seeing as the structure is zeroed. > > Also this is the IO-APIC RTE, so it feels a bit out of place to use > the local APIC defines? Maybe. There is a certain level of correlation, but yes, it may end up being confusing. > I will add a comment if you are fine with it. I am. Jan
|
![]() |
Lists.xenproject.org is hosted with RackSpace, monitoring our |