[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v2 13/35] xen/console: rename console_input_domain



On Wednesday, December 11th, 2024 at 9:17 AM, Roger Pau Monné 
<roger.pau@xxxxxxxxxx> wrote:

>
>
> On Thu, Dec 05, 2024 at 08:41:43PM -0800, Denis Mukhin via B4 Relay wrote:
>
> > From: Denis Mukhin dmukhin@xxxxxxxx
> >
> > console_input_domain() takes an RCU lock to protect domain structure.
> > That implies call to rcu_unlock_domain() after use.
> >
> > Rename console_input_domain() to rcu_lock_domain_console_owner() to
> > highlight the need of calling rcu_unlock_domain().
> >
> > Signed-off-by: Denis Mukhin dmukhin@xxxxxxxx
> > ---
> > xen/arch/arm/vpl011.c | 2 +-
> > xen/drivers/char/console.c | 2 +-
> > xen/include/xen/console.h | 2 +-
> > 3 files changed, 3 insertions(+), 3 deletions(-)
> >
> > diff --git a/xen/arch/arm/vpl011.c b/xen/arch/arm/vpl011.c
> > index 
> > fe36fe2bd1529a4114884580ded6d6fa55a22f0e..4d682e98553303b4a12f5cd7e5e67ab096cd7cc2
> >  100644
> > --- a/xen/arch/arm/vpl011.c
> > +++ b/xen/arch/arm/vpl011.c
> > @@ -78,7 +78,7 @@ static void vpl011_write_data_xen(struct domain *d, 
> > uint8_t data)
> > unsigned long flags;
> > struct vpl011 *vpl011 = &d->arch.vpl011;
> > struct vpl011_xen_backend *intf = vpl011->backend.xen;
> > - struct domain *input = console_input_domain();
> > + struct domain *input = rcu_lock_domain_console_owner();
>
>
> May I suggest console_get_domain() and then introducing a
> console_put_domain() which is just a wrapper around
> rcu_unlock_domain()?

Agreed, that looks even better! Thanks.

Fixed.

>
> Thanks, Roger.





 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.