[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [XEN PATCH v5 16/17] CODING_STYLE: Add a section on header guards naming conventions
This section explains which format should be followed by header inclusion guards via a drop-down list of rules. No functional change. Signed-off-by: Alessandro Zucchelli <alessandro.zucchelli@xxxxxxxxxxx> --- Changes in v5: - edit inclusion guards naming conventions, according to feedback received --- CODING_STYLE | 21 +++++++++++++++++++++ 1 file changed, 21 insertions(+) diff --git a/CODING_STYLE b/CODING_STYLE index 7f6e9ad065..f4f26a3cd8 100644 --- a/CODING_STYLE +++ b/CODING_STYLE @@ -159,6 +159,27 @@ Emacs local variables A comment block containing local variables for emacs is permitted at the end of files. It should be: +Header inclusion guards +----------------------- + +Unless differently specified all header files should have proper inclusion +guards in order to avoid being included multiple times. +The following naming conventions have been devised: + +- private headers -> <dir>__<filename>_H + - arch/arm/arm64/lib/something.h -> ARM__ARM64__LIB__SOMETHING_H + - arch/arm/arm32/lib/something.h -> ARM__ARM32__LIB__SOMETHING_H + - arch/x86/lib/something.h -> X86__LIB__SOMETHING_H + +- asm-generic headers -> ASM_GENERIC__<filename>_H + - include/asm-generic/something.h -> ASM_GENERIC__SOMETHING_H + +- arch/<architecture>/include/asm/<subdir>/<filename>.h -> ASM__<architecture>__<subdir>__<filename>_H + - arch/x86/include/asm/something.h -> ASM__X86__SOMETHING_H + +- include/xen -> XEN__<filename>_H + - include/xen/something.h -> XEN__SOMETHING_H + /* * Local variables: * mode: C -- 2.34.1
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |