[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [RFC PATCH 17/17] CODING_STYLE: Add a section on header guards naming conventions
This section explains which format should be followed by header inclusion guards via a drop-down list of rules. No functional change. Signed-off-by: Alessandro Zucchelli <alessandro.zucchelli@xxxxxxxxxxx> --- CODING_STYLE | 19 +++++++++++++++++++ 1 file changed, 19 insertions(+) diff --git a/CODING_STYLE b/CODING_STYLE index 7f6e9ad065..87836c97d4 100644 --- a/CODING_STYLE +++ b/CODING_STYLE @@ -167,3 +167,22 @@ the end of files. It should be: * indent-tabs-mode: nil * End: */ + +Header inclusion guards +----------------------- + +Unless differently specified all header files should have proper inclusion +guards in order to avoid being included multiple times. +The following naming conventions have been devised: +- private headers -> <dir>_<filename>_H +- asm-generic headers -> ASM_GENERIC_<filename>_H + - #ifndef ASM_GENERIC_X86_PERCPU_H + #define ASM_GENERIC_X86_PERCPU_H + //... + #endif /* ASM_GENERIC_X86_PERCPU_H */ +- arch/<architecture>/include/asm/<subdir>/<filename>.h -> ASM_<architecture>_<subdir>_<filename>_H + - #ifndef ASM_X86_DOMAIN_H + #define ASM_X86_DOMAIN_H + //... + #endif /* ASM_X86_DOMAIN_H */ + -- 2.34.1
|
![]() |
Lists.xenproject.org is hosted with RackSpace, monitoring our |