[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [PATCH v15 3/5] vpci: add initial support for virtual PCI bus topology
On Fri, May 17, 2024 at 01:06:13PM -0400, Stewart Hildebrand wrote: > From: Oleksandr Andrushchenko <oleksandr_andrushchenko@xxxxxxxx> > > Assign SBDF to the PCI devices being passed through with bus 0. > The resulting topology is where PCIe devices reside on the bus 0 of the > root complex itself (embedded endpoints). > This implementation is limited to 32 devices which are allowed on > a single PCI bus. > > Please note, that at the moment only function 0 of a multifunction > device can be passed through. > > Signed-off-by: Oleksandr Andrushchenko <oleksandr_andrushchenko@xxxxxxxx> > Signed-off-by: Volodymyr Babchuk <volodymyr_babchuk@xxxxxxxx> > Signed-off-by: Stewart Hildebrand <stewart.hildebrand@xxxxxxx> > Acked-by: Jan Beulich <jbeulich@xxxxxxxx> > --- > In v15: > - add Jan's A-b > In v13: > - s/depends on/select/ in Kconfig > - check pdev->sbdf.fn instead of two booleans in add_virtual_device() > - comment #endifs in sched.h > - clarify comment about limits in vpci.h with seg/bus limit > In v11: > - Fixed code formatting > - Removed bogus write_unlock() call > - Fixed type for new_dev_number > In v10: > - Removed ASSERT(pcidevs_locked()) > - Removed redundant code (local sbdf variable, clearing sbdf during > device removal, etc) > - Added __maybe_unused attribute to "out:" label > - Introduced HAS_VPCI_GUEST_SUPPORT Kconfig option, as this is the > first patch where it is used (previously was in "vpci: add hooks for > PCI device assign/de-assign") > In v9: > - Lock in add_virtual_device() replaced with ASSERT (thanks, Stewart) > In v8: > - Added write lock in add_virtual_device > Since v6: > - re-work wrt new locking scheme > - OT: add ASSERT(pcidevs_write_locked()); to add_virtual_device() > Since v5: > - s/vpci_add_virtual_device/add_virtual_device and make it static > - call add_virtual_device from vpci_assign_device and do not use > REGISTER_VPCI_INIT machinery > - add pcidevs_locked ASSERT > - use DECLARE_BITMAP for vpci_dev_assigned_map > Since v4: > - moved and re-worked guest sbdf initializers > - s/set_bit/__set_bit > - s/clear_bit/__clear_bit > - minor comment fix s/Virtual/Guest/ > - added VPCI_MAX_VIRT_DEV constant (PCI_SLOT(~0) + 1) which will be used > later for counting the number of MMIO handlers required for a guest > (Julien) > Since v3: > - make use of VPCI_INIT > - moved all new code to vpci.c which belongs to it > - changed open-coded 31 to PCI_SLOT(~0) > - added comments and code to reject multifunction devices with > functions other than 0 > - updated comment about vpci_dev_next and made it unsigned int > - implement roll back in case of error while assigning/deassigning devices > - s/dom%pd/%pd > Since v2: > - remove casts that are (a) malformed and (b) unnecessary > - add new line for better readability > - remove CONFIG_HAS_VPCI_GUEST_SUPPORT ifdef's as the relevant vPCI > functions are now completely gated with this config > - gate common code with CONFIG_HAS_VPCI_GUEST_SUPPORT > New in v2 > --- > xen/drivers/Kconfig | 4 +++ > xen/drivers/vpci/vpci.c | 57 +++++++++++++++++++++++++++++++++++++++++ > xen/include/xen/sched.h | 10 +++++++- > xen/include/xen/vpci.h | 12 +++++++++ > 4 files changed, 82 insertions(+), 1 deletion(-) > > diff --git a/xen/drivers/Kconfig b/xen/drivers/Kconfig > index db94393f47a6..20050e9bb8b3 100644 > --- a/xen/drivers/Kconfig > +++ b/xen/drivers/Kconfig > @@ -15,4 +15,8 @@ source "drivers/video/Kconfig" > config HAS_VPCI > bool > > +config HAS_VPCI_GUEST_SUPPORT > + bool > + select HAS_VPCI > + > endmenu > diff --git a/xen/drivers/vpci/vpci.c b/xen/drivers/vpci/vpci.c > index 97e115dc5798..23722634d50b 100644 > --- a/xen/drivers/vpci/vpci.c > +++ b/xen/drivers/vpci/vpci.c > @@ -40,6 +40,49 @@ extern vpci_register_init_t *const __start_vpci_array[]; > extern vpci_register_init_t *const __end_vpci_array[]; > #define NUM_VPCI_INIT (__end_vpci_array - __start_vpci_array) > > +#ifdef CONFIG_HAS_VPCI_GUEST_SUPPORT > +static int add_virtual_device(struct pci_dev *pdev) This seems quite generic, IMO it would better named `assign_{guest,virtual}_sbdf()` or similar, unless there are plans to add more code here that's not strictly only about setting the guest SBDF. > +{ > + struct domain *d = pdev->domain; > + unsigned int new_dev_number; > + > + if ( is_hardware_domain(d) ) > + return 0; > + > + ASSERT(rw_is_write_locked(&pdev->domain->pci_lock)); Shouldn't the assert be done before the is_hardware_domain() check, so that we assert that all possible paths (even those from dom0) have taken the correct lock? > + > + /* > + * Each PCI bus supports 32 devices/slots at max or up to 256 when > + * there are multi-function ones which are not yet supported. > + */ > + if ( pdev->sbdf.fn ) > + { > + gdprintk(XENLOG_ERR, "%pp: only function 0 passthrough supported\n", > + &pdev->sbdf); > + return -EOPNOTSUPP; > + } > + new_dev_number = find_first_zero_bit(d->vpci_dev_assigned_map, > + VPCI_MAX_VIRT_DEV); > + if ( new_dev_number == VPCI_MAX_VIRT_DEV ) > + return -ENOSPC; > + > + __set_bit(new_dev_number, &d->vpci_dev_assigned_map); > + > + /* > + * Both segment and bus number are 0: > + * - we emulate a single host bridge for the guest, e.g. segment 0 > + * - with bus 0 the virtual devices are seen as embedded > + * endpoints behind the root complex > + * > + * TODO: add support for multi-function devices. > + */ > + pdev->vpci->guest_sbdf = PCI_SBDF(0, 0, new_dev_number, 0); > + > + return 0; > +} > + > +#endif /* CONFIG_HAS_VPCI_GUEST_SUPPORT */ > + > void vpci_deassign_device(struct pci_dev *pdev) > { > unsigned int i; > @@ -49,6 +92,12 @@ void vpci_deassign_device(struct pci_dev *pdev) > if ( !has_vpci(pdev->domain) || !pdev->vpci ) > return; > > +#ifdef CONFIG_HAS_VPCI_GUEST_SUPPORT > + if ( pdev->vpci->guest_sbdf.sbdf != ~0 ) > + __clear_bit(pdev->vpci->guest_sbdf.dev, > + &pdev->domain->vpci_dev_assigned_map); > +#endif > + > spin_lock(&pdev->vpci->lock); > while ( !list_empty(&pdev->vpci->handlers) ) > { > @@ -103,6 +152,13 @@ int vpci_assign_device(struct pci_dev *pdev) > INIT_LIST_HEAD(&pdev->vpci->handlers); > spin_lock_init(&pdev->vpci->lock); > > +#ifdef CONFIG_HAS_VPCI_GUEST_SUPPORT > + pdev->vpci->guest_sbdf.sbdf = ~0; I think ~0 wants to be in a define here: #define INVALID_GUEST_SBDF ~0 Or similar. Thanks, Roger.
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |