[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [XEN PATCH 2/2] automation/eclair: add deviation for Rule 16.4
On Fri, 3 May 2024, Federico Serafini wrote: > MISRA C:2012 Rule 16.4 states that "Every switch statement shall have a > default label". > Update ECLAIR configuration to take into account the deviations > agreed during MISRA meetings. > > Signed-off-by: Federico Serafini <federico.serafini@xxxxxxxxxxx> Reviewed-by: Stefano Stabellini <sstabellini@xxxxxxxxxx> > --- > automation/eclair_analysis/ECLAIR/deviations.ecl | 8 ++++++++ > docs/misra/deviations.rst | 13 +++++++++++++ > 2 files changed, 21 insertions(+) > > diff --git a/automation/eclair_analysis/ECLAIR/deviations.ecl > b/automation/eclair_analysis/ECLAIR/deviations.ecl > index d21f112a9b..f09ad71acf 100644 > --- a/automation/eclair_analysis/ECLAIR/deviations.ecl > +++ b/automation/eclair_analysis/ECLAIR/deviations.ecl > @@ -384,6 +384,14 @@ explicit comment indicating the fallthrough intention is > present." > -config=MC3R1.R16.3,reports+={safe, > "any_area(end_loc(any_exp(text(^(?s).*/\\* [fF]all ?through.? > \\*/.*$,0..1))))"} > -doc_end > > +-doc_begin="Switch statements having a controlling expression of enum type > deliberately do not have a default case: gcc -Wall enables -Wswitch which > warns (and breaks the build as we use -Werror) if one of the enum labels is > missing from the switch." > +-config=MC3R1.R16.4,reports+={deliberate,'any_area(kind(context)&&^.* has no > `default.*$&&stmt(node(switch_stmt)&&child(cond,skip(__non_syntactic_paren_stmts,type(canonical(enum_underlying_type(any())))))))'} > +-doc_end > + > +-doc_begin="A switch statement with a single switch clause and no default > label may be used in place of an equivalent if statement if it is considered > to improve readability." > +-config=MC3R1.R16.4,switch_clauses+={deliberate,"switch(1)&&default(0)"} > +-doc_end > + > -doc_begin="A switch statement with a single switch clause and no default > label may be used in place of an equivalent if statement if it is considered > to improve readability." > -config=MC3R1.R16.6,switch_clauses+={deliberate, "default(0)"} > -doc_end > diff --git a/docs/misra/deviations.rst b/docs/misra/deviations.rst > index ed0c1e8ed0..39cc321a27 100644 > --- a/docs/misra/deviations.rst > +++ b/docs/misra/deviations.rst > @@ -334,6 +334,19 @@ Deviations related to MISRA C:2012 Rules: > - /\* Fallthrough \*/ > - /\* Fallthrough. \*/ > > + * - R16.4 > + - Switch statements having a controlling expression of enum type > + deliberately do not have a default case: gcc -Wall enables -Wswitch > + which warns (and breaks the build as we use -Werror) if one of the > enum > + labels is missing from the switch. > + - Tagged as `deliberate` for ECLAIR. > + > + * - R16.4 > + - A switch statement with a single switch clause and no default label > may > + be used in place of an equivalent if statement if it is considered to > + improve readability. > + - Tagged as `deliberate` for ECLAIR. > + > * - R16.6 > - A switch statement with a single switch clause and no default label > may > be used in place of an equivalent if statement if it is considered to > -- > 2.34.1 >
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |