[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [XEN PATCH] xen/hypercalls: address violations of MISRA C:2012 Rule 8.3
On Fri, 11 Aug 2023, Federico Serafini wrote: > Uniform the auto-generated hypercall-decls with the corresponding > definitions to address violations of MISRA C:2012 Rule 8.3: > "All declarations of an object or function shall use the same names and > type qualifiers". > > No functional change. > > Signed-off-by: Federico Serafini <federico.serafini@xxxxxxxxxxx> > --- > xen/include/hypercall-defs.c | 11 ++++++++--- > 1 file changed, 8 insertions(+), 3 deletions(-) > > diff --git a/xen/include/hypercall-defs.c b/xen/include/hypercall-defs.c > index 6d361ddfce..4feddce571 100644 > --- a/xen/include/hypercall-defs.c > +++ b/xen/include/hypercall-defs.c > @@ -107,11 +107,16 @@ defhandle: physdev_op_compat_t > prefix: do PREFIX_hvm PREFIX_compat PREFIX_do_arm > physdev_op(int cmd, void *arg) > > -prefix: do PREFIX_hvm PREFIX_compat > +prefix: do PREFIX_hvm > #if defined(CONFIG_GRANT_TABLE) || defined(CONFIG_PV_SHIM) > grant_table_op(unsigned int cmd, void *uop, unsigned int count) > #endif > > +prefix: PREFIX_compat > +#if defined(CONFIG_GRANT_TABLE) || defined(CONFIG_PV_SHIM) > +grant_table_op(unsigned int cmd, void *cmp_uop, unsigned int count) > +#endif Everything checks out, so: Reviewed-by: Stefano Stabellini <sstabellini@xxxxxxxxxx> The other changes are uncontroversial. This one about splitting out the compat version of grant_table_op is not great. I wonder if it would be better to rename cmp_uop to uop in xen/common/compat/grant_table.c. I'll let Jan and the others decide I am OK either way. > prefix: do PREFIX_hvm > memory_op(unsigned long cmd, void *arg) > > @@ -136,7 +141,7 @@ xenoprof_op(int op, void *arg) > prefix: compat > set_timer_op(uint32_t lo, int32_t hi) > multicall(multicall_entry_compat_t *call_list, uint32_t nr_calls) > -memory_op(unsigned int cmd, void *arg) > +memory_op(unsigned int cmd, void *compat) > #ifdef CONFIG_IOREQ_SERVER > dm_op(domid_t domid, unsigned int nr_bufs, void *bufs) > #endif > @@ -172,7 +177,7 @@ console_io(unsigned int cmd, unsigned int count, char > *buffer) > vm_assist(unsigned int cmd, unsigned int type) > event_channel_op(int cmd, void *arg) > mmuext_op(mmuext_op_t *uops, unsigned int count, unsigned int *pdone, > unsigned int foreigndom) > -multicall(multicall_entry_t *call_list, unsigned int nr_calls) > +multicall(multicall_entry_t *call_list, uint32_t nr_calls) > #ifdef CONFIG_PV > mmu_update(mmu_update_t *ureqs, unsigned int count, unsigned int *pdone, > unsigned int foreigndom) > stack_switch(unsigned long ss, unsigned long esp) > -- > 2.34.1 >
|
![]() |
Lists.xenproject.org is hosted with RackSpace, monitoring our |