[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [XEN PATCH 2/5] x86: change parameter names of nestedhvm_vcpu_iomap_get() definition
Change parameter names of nestedhvm_vcpu_iomap_get() definition to those used in the function declaration in order to: 1) improve readability; 2) fix violations of MISRA C:2012 Rule 8.3. Signed-off-by: Federico Serafini <federico.serafini@xxxxxxxxxxx> --- xen/arch/x86/hvm/nestedhvm.c | 10 +++++----- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/xen/arch/x86/hvm/nestedhvm.c b/xen/arch/x86/hvm/nestedhvm.c index ec68551127..64d7eec9a1 100644 --- a/xen/arch/x86/hvm/nestedhvm.c +++ b/xen/arch/x86/hvm/nestedhvm.c @@ -155,19 +155,19 @@ static int __init cf_check nestedhvm_setup(void) __initcall(nestedhvm_setup); unsigned long * -nestedhvm_vcpu_iomap_get(bool_t port_80, bool_t port_ed) +nestedhvm_vcpu_iomap_get(bool_t ioport_80, bool_t ioport_ed) { int i; if (!hvm_port80_allowed) - port_80 = 1; + ioport_80 = 1; - if (port_80 == 0) { - if (port_ed == 0) + if (ioport_80 == 0) { + if (ioport_ed == 0) return hvm_io_bitmap; i = 0; } else { - if (port_ed == 0) + if (ioport_ed == 0) i = 1; else i = 2; -- 2.34.1
|
![]() |
Lists.xenproject.org is hosted with RackSpace, monitoring our |