[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [PATCH 1/2] xen/virtio: Fix n_pages calculation in xen_grant_dma_map(unmap)_page()
On 06.10.22 12:14, Oleksandr Tyshchenko wrote: On Thu, Oct 6, 2022 at 11:05 AM Juergen Gross <jgross@xxxxxxxx <mailto:jgross@xxxxxxxx>> wrote:On 06.10.22 09:35, Xenia Ragiadakou wrote: Hello Xenia, Juergen [sorry for the possible format issues] > > On 10/5/22 20:48, Oleksandr Tyshchenko wrote: >> From: Oleksandr Tyshchenko <oleksandr_tyshchenko@xxxxxxxx <mailto:oleksandr_tyshchenko@xxxxxxxx>> >> >> Take page offset into the account when calculating the number of pages >> to be granted. >> >> Signed-off-by: Oleksandr Tyshchenko <oleksandr_tyshchenko@xxxxxxxx <mailto:oleksandr_tyshchenko@xxxxxxxx>> >> Fixes: d6aca3504c7d ("xen/grant-dma-ops: Add option to restrict memory access >> under Xen") >> --- >> drivers/xen/grant-dma-ops.c | 5 +++-- >> 1 file changed, 3 insertions(+), 2 deletions(-) >> >> diff --git a/drivers/xen/grant-dma-ops.c b/drivers/xen/grant-dma-ops.c >> index 8973fc1e9ccc..1998d0e8ce82 100644 >> --- a/drivers/xen/grant-dma-ops.c >> +++ b/drivers/xen/grant-dma-ops.c >> @@ -153,7 +153,7 @@ static dma_addr_t xen_grant_dma_map_page(struct device >> *dev, struct page *page, >> unsigned long attrs) >> { >> struct xen_grant_dma_data *data; >> - unsigned int i, n_pages = PFN_UP(size); >> + unsigned int i, n_pages = PFN_UP(offset + size); > > Here, why do we use PFN_UP and not XEN_PFN_UP? > Also, since the variable 'n_pages' seems to refer to the number of grants > (unless I got it all entirely wrong ...), wouldn't it be more suitable to call > explicitly gnttab_count_grant()? Good point. +1 I think this will need another patch for switching grant-dma-ops.c to use XEN_PAGE_SIZE and XEN_PAGE_SHIFT. +1I can create a separate patch for converting on top of this series, it would be nice to clarify one point.So I will convert PAGE_SIZE/PAGE_SHIFT to XEN_PAGE_SIZE/XEN_PAGE_SHIFT respectively (where appropriate). Yes, that would be the idea. Should the PFN_UP be converted to XEN_PFN_UP *or* use gnttab_count_grant() explicitly? Personally I would prefer the former, but would also be ok with the latter. I agree XEN_PFN_UP would be better, especially as XEN_PAGE_SIZE/XEN_PAGE_SHIFT will be used in the same functions. Juergen Attachment:
OpenPGP_0xB0DE9DD628BF132F.asc Attachment:
OpenPGP_signature
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |