[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problems with APIC on versions 4.9 and later (4.8 works)


Sorry for the simultaneous post on xen-users and xen-devel, but as I noted that the problem appears only for versions of xen that are >= 4.9, I think that developers may have a look at this.

I recently bought a generic mainboard and a Xeon E5-2926v2 CPU, it is a 12 core, 24 threads cpu.

My system was already running on another machine with xen 4.11 on a debian 10 system and after replacing the mainboard it didn't boot. 

After many tries I noticed that downgrading to the previous version of Xen (4.8, available on Debian 9) works well. I also tried a lot of variations for the dom0 kernel, all of them with the same results.

All my tests were done with 4.11, but I checked with a live version of Alpine Linux (3.7.3, with Xen 4.9.4) that the system doesn't boot on that release also.

With more research I noticed that if I limit dom0 to use only one CPU (dom0_max_vcpus=1) the system boots up, I didn't check if guest VM worked, but I suppose that they would not be able to use the other 23 vcpus available, anyway, a system with one vcpu for dom0 would be very slow I think.

I've noticed also that if I keep dom0 to use more than one core but disable acpi on the dom0 kernel, it boots up, unfortunately this is not sufficient because I cannot use any device attached to the system (not even the usb keyboard). This only helps to detect that the problem may be in the ACPI/APIC code.

I tried many variations with parameters related with ACPI and APIC. None of them was satisfactory, always ended on a halted system or a self rebooting one.

Can anyone point me to a solution for this?

Best regards,



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.