[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [PATCH v12 02/27] tools/libxenevtchn: rename open_flags to flags
Rename the xenevtchn_open() parameter open_flags to flags as it might be used for things not passed on to open(). No functional change. No API/ABI changes. Suggested-by: Andrew Cooper <andrew.cooper3@xxxxxxxxxx> Signed-off-by: Juergen Gross <jgross@xxxxxxxx> Reviewed-by: Andrew Cooper <andrew.cooper3@xxxxxxxxxx> --- V11: - new patch (Andrew Cooper) V12: - added "No API/ABI changes" to commit message (Andrew Cooper) --- tools/include/xenevtchn.h | 2 +- tools/libs/evtchn/core.c | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff --git a/tools/include/xenevtchn.h b/tools/include/xenevtchn.h index 91821ee56d..3e9b6e7323 100644 --- a/tools/include/xenevtchn.h +++ b/tools/include/xenevtchn.h @@ -67,7 +67,7 @@ struct xentoollog_logger; */ /* Currently no flags are defined */ xenevtchn_handle *xenevtchn_open(struct xentoollog_logger *logger, - unsigned open_flags); + unsigned int flags); /* * Close a handle previously allocated with xenevtchn_open(). diff --git a/tools/libs/evtchn/core.c b/tools/libs/evtchn/core.c index 8090d0ce87..72d92e28bf 100644 --- a/tools/libs/evtchn/core.c +++ b/tools/libs/evtchn/core.c @@ -29,7 +29,7 @@ static int all_restrict_cb(Xentoolcore__Active_Handle *ah, domid_t domid) return xenevtchn_restrict(xce, domid); } -xenevtchn_handle *xenevtchn_open(xentoollog_logger *logger, unsigned open_flags) +xenevtchn_handle *xenevtchn_open(xentoollog_logger *logger, unsigned int flags) { xenevtchn_handle *xce = malloc(sizeof(*xce)); int rc; -- 2.26.2
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |