[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [PATCH v4 0/2] xen/balloon: fixes for memory hotplug
Hello, The following series contain some fixes in order to split Xen unpopulated memory handling from the ballooning driver if ZONE_DEVICE is available, so that physical memory regions used to map foreign pages are not tied to memory hotplug. The main difference in this version is that MEMORY_DEVICE_DEVDAX is renamed to MEMORY_DEVICE_GENERIC, as using DEVDAX in the Xen code to allocate unpopulated memory felt wrong. Thanks, Roger. Roger Pau Monne (2): memremap: rename MEMORY_DEVICE_DEVDAX to MEMORY_DEVICE_GENERIC xen: add helpers to allocate unpopulated memory drivers/dax/device.c | 2 +- drivers/gpu/drm/xen/xen_drm_front_gem.c | 9 +- drivers/xen/Kconfig | 4 + drivers/xen/Makefile | 1 + drivers/xen/balloon.c | 4 +- drivers/xen/grant-table.c | 4 +- drivers/xen/privcmd.c | 4 +- drivers/xen/unpopulated-alloc.c | 185 ++++++++++++++++++++++++ drivers/xen/xenbus/xenbus_client.c | 6 +- drivers/xen/xlate_mmu.c | 4 +- include/linux/memremap.h | 9 +- include/xen/xen.h | 9 ++ mm/memremap.c | 2 +- 13 files changed, 221 insertions(+), 22 deletions(-) create mode 100644 drivers/xen/unpopulated-alloc.c -- 2.28.0
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |