[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [RFC PATCH V1 05/12] hvm/dm: Introduce xendevicemodel_set_irq_level DM op
On Mon, 3 Aug 2020, Oleksandr Tyshchenko wrote: > From: Oleksandr Tyshchenko <oleksandr_tyshchenko@xxxxxxxx> > > This patch adds ability to the device emulator to notify otherend > (some entity running in the guest) using a SPI and implements Arm > specific bits for it. Proposed interface allows emulator to set > the logical level of a one of a domain's IRQ lines. > > Please note, this is a split/cleanup of Julien's PoC: > "Add support for Guest IO forwarding to a device emulator" > > Signed-off-by: Julien Grall <julien.grall@xxxxxxx> > Signed-off-by: Oleksandr Tyshchenko <oleksandr_tyshchenko@xxxxxxxx> > --- > tools/libs/devicemodel/core.c | 18 ++++++++++++++++++ > tools/libs/devicemodel/include/xendevicemodel.h | 4 ++++ > tools/libs/devicemodel/libxendevicemodel.map | 1 + > xen/arch/arm/dm.c | 22 +++++++++++++++++++++- > xen/common/hvm/dm.c | 1 + > xen/include/public/hvm/dm_op.h | 15 +++++++++++++++ > 6 files changed, 60 insertions(+), 1 deletion(-) > > diff --git a/tools/libs/devicemodel/core.c b/tools/libs/devicemodel/core.c > index 4d40639..30bd79f 100644 > --- a/tools/libs/devicemodel/core.c > +++ b/tools/libs/devicemodel/core.c > @@ -430,6 +430,24 @@ int xendevicemodel_set_isa_irq_level( > return xendevicemodel_op(dmod, domid, 1, &op, sizeof(op)); > } > > +int xendevicemodel_set_irq_level( > + xendevicemodel_handle *dmod, domid_t domid, uint32_t irq, > + unsigned int level) It is a pity that having xen_dm_op_set_pci_intx_level and xen_dm_op_set_isa_irq_level already we need to add a third one, but from the names alone I don't think we can reuse either of them. It is very similar to set_isa_irq_level. We could almost rename xendevicemodel_set_isa_irq_level to xendevicemodel_set_irq_level or, better, just add an alias to it so that xendevicemodel_set_irq_level is implemented by calling xendevicemodel_set_isa_irq_level. Honestly I am not sure if it is worth doing it though. Any other opinions? But I think we should plan for not needing two calls (one to set level to 1, and one to set it to 0): https://marc.info/?l=xen-devel&m=159535112027405 > +{ > + struct xen_dm_op op; > + struct xen_dm_op_set_irq_level *data; > + > + memset(&op, 0, sizeof(op)); > + > + op.op = XEN_DMOP_set_irq_level; > + data = &op.u.set_irq_level; > + > + data->irq = irq; > + data->level = level; > + > + return xendevicemodel_op(dmod, domid, 1, &op, sizeof(op)); > +} > + > int xendevicemodel_set_pci_link_route( > xendevicemodel_handle *dmod, domid_t domid, uint8_t link, uint8_t irq) > { > diff --git a/tools/libs/devicemodel/include/xendevicemodel.h > b/tools/libs/devicemodel/include/xendevicemodel.h > index e877f5c..c06b3c8 100644 > --- a/tools/libs/devicemodel/include/xendevicemodel.h > +++ b/tools/libs/devicemodel/include/xendevicemodel.h > @@ -209,6 +209,10 @@ int xendevicemodel_set_isa_irq_level( > xendevicemodel_handle *dmod, domid_t domid, uint8_t irq, > unsigned int level); > > +int xendevicemodel_set_irq_level( > + xendevicemodel_handle *dmod, domid_t domid, unsigned int irq, > + unsigned int level); > + > /** > * This function maps a PCI INTx line to a an IRQ line. > * > diff --git a/tools/libs/devicemodel/libxendevicemodel.map > b/tools/libs/devicemodel/libxendevicemodel.map > index 561c62d..a0c3012 100644 > --- a/tools/libs/devicemodel/libxendevicemodel.map > +++ b/tools/libs/devicemodel/libxendevicemodel.map > @@ -32,6 +32,7 @@ VERS_1.2 { > global: > xendevicemodel_relocate_memory; > xendevicemodel_pin_memory_cacheattr; > + xendevicemodel_set_irq_level; > } VERS_1.1; > > VERS_1.3 { > diff --git a/xen/arch/arm/dm.c b/xen/arch/arm/dm.c > index 2437099..8431805 100644 > --- a/xen/arch/arm/dm.c > +++ b/xen/arch/arm/dm.c > @@ -20,7 +20,27 @@ > int arch_dm_op(struct xen_dm_op *op, struct domain *d, > const struct dmop_args *op_args, bool *const_op) > { > - return -EOPNOTSUPP; > + int rc; > + > + switch ( op->op ) > + { > + case XEN_DMOP_set_irq_level: > + { > + const struct xen_dm_op_set_irq_level *data = > + &op->u.set_irq_level; > + > + /* XXX: Handle check */ > + vgic_inject_irq(d, NULL, data->irq, data->level); > + rc = 0; > + break; > + } > + > + default: > + rc = -EOPNOTSUPP; > + break; > + } > + > + return rc; > } > > /* > diff --git a/xen/common/hvm/dm.c b/xen/common/hvm/dm.c > index 09e9542..e2e1250 100644 > --- a/xen/common/hvm/dm.c > +++ b/xen/common/hvm/dm.c > @@ -47,6 +47,7 @@ static int dm_op(const struct dmop_args *op_args) > [XEN_DMOP_remote_shutdown] = sizeof(struct > xen_dm_op_remote_shutdown), > [XEN_DMOP_relocate_memory] = sizeof(struct > xen_dm_op_relocate_memory), > [XEN_DMOP_pin_memory_cacheattr] = sizeof(struct > xen_dm_op_pin_memory_cacheattr), > + [XEN_DMOP_set_irq_level] = sizeof(struct > xen_dm_op_set_irq_level), > }; > > rc = rcu_lock_remote_domain_by_id(op_args->domid, &d); > diff --git a/xen/include/public/hvm/dm_op.h b/xen/include/public/hvm/dm_op.h > index fd00e9d..c45d29e 100644 > --- a/xen/include/public/hvm/dm_op.h > +++ b/xen/include/public/hvm/dm_op.h > @@ -417,6 +417,20 @@ struct xen_dm_op_pin_memory_cacheattr { > uint32_t pad; > }; > > +/* > + * XEN_DMOP_set_irq_level: Set the logical level of a one of a domain's > + * IRQ lines. > + * XXX Handle PPIs. > + */ > +#define XEN_DMOP_set_irq_level 19 > + > +struct xen_dm_op_set_irq_level { > + uint32_t irq; > + /* IN - Level: 0 -> deasserted, 1 -> asserted */ > + uint8_t level; > +}; > + > + > struct xen_dm_op { > uint32_t op; > uint32_t pad; > @@ -430,6 +444,7 @@ struct xen_dm_op { > struct xen_dm_op_track_dirty_vram track_dirty_vram; > struct xen_dm_op_set_pci_intx_level set_pci_intx_level; > struct xen_dm_op_set_isa_irq_level set_isa_irq_level; > + struct xen_dm_op_set_irq_level set_irq_level; > struct xen_dm_op_set_pci_link_route set_pci_link_route; > struct xen_dm_op_modified_memory modified_memory; > struct xen_dm_op_set_mem_type set_mem_type; > -- > 2.7.4 >
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |