[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [PATCH v2 08/11] swiotlb-xen: introduce phys_to_dma/dma_to_phys translations
On Wed, Jun 03, 2020 at 03:22:44PM -0700, Stefano Stabellini wrote: > From: Stefano Stabellini <stefano.stabellini@xxxxxxxxxx> > > With some devices physical addresses are different than dma addresses. > To be able to deal with these cases, we need to call phys_to_dma on > physical addresses (including machine addresses in Xen terminology) > before returning them from xen_swiotlb_alloc_coherent and > xen_swiotlb_map_page. > > We also need to convert dma addresses back to physical addresses using > dma_to_phys in xen_swiotlb_free_coherent and xen_swiotlb_unmap_page if > we want to do any operations on them. > > Call dma_to_phys in is_xen_swiotlb_buffer. > Call phys_to_dma in xen_phys_to_bus. > Call dma_to_phys in xen_bus_to_phys. > > Everything is taken care of by these changes except for > xen_swiotlb_alloc_coherent and xen_swiotlb_free_coherent, which need a > few explicit phys_to_dma/dma_to_phys calls. > > Signed-off-by: Stefano Stabellini <stefano.stabellini@xxxxxxxxxx> > Tested-by: Corey Minyard <cminyard@xxxxxxxxxx> > Tested-by: Roman Shaposhnik <roman@xxxxxxxxxx> > --- > Changes in v2: > - improve commit message > --- > drivers/xen/swiotlb-xen.c | 22 ++++++++++++---------- > 1 file changed, 12 insertions(+), 10 deletions(-) > > diff --git a/drivers/xen/swiotlb-xen.c b/drivers/xen/swiotlb-xen.c > index 0a6cb67f0fc4..60ef07440905 100644 > --- a/drivers/xen/swiotlb-xen.c > +++ b/drivers/xen/swiotlb-xen.c > @@ -64,16 +64,16 @@ static inline dma_addr_t xen_phys_to_bus(struct device > *dev, phys_addr_t paddr) > > dma |= paddr & ~XEN_PAGE_MASK; > > - return dma; > + return phys_to_dma(dev, dma); So looking at this function: The dma name for something passed to phys_to_dma is really weird. The fact that the comments says don't use XEN_PFN_PHYS beause of the type mismatch while nothing but swiotlb-xen is the only user of XEN_PFN_PHYS is also weird. I think XEN_PFN_PHYS needs to move to swiotlb-xen first, then use a hardcoded u64 for the size, and the split the function into a phys_to_xen_phys (or so) function where the result gets passed to phys_to_dma. Similar for the reverse direction.
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |