[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH v4 05/15] x86: implement get hw info flow for MBA
On Sat, Sep 23, 2017 at 09:48:14AM +0000, Yi Sun wrote: > This patch implements get HW info flow for MBA including its callback > function and sysctl interface. > > Signed-off-by: Yi Sun <yi.y.sun@xxxxxxxxxxxxxxx> > --- > CC: Jan Beulich <jbeulich@xxxxxxxx> > CC: Andrew Cooper <andrew.cooper3@xxxxxxxxxx> > CC: Wei Liu <wei.liu2@xxxxxxxxxx> > CC: Roger Pau Monné <roger.pau@xxxxxxxxxx> > CC: Chao Peng <chao.p.peng@xxxxxxxxxxxxxxx> > > v4: > - remove 'ALLOC_' from macro names. > (suggested by Roger Pau Monné) > - initialize 'data[PSR_INFO_ARRAY_SIZE]' to 0 to prevent to leak stack > data. > (suggested by Roger Pau Monné) > v3: > - replace 'PSR_VAL_TYPE_MBA' to 'PSR_TYPE_MBA_THRTL'. > (suggested by Roger Pau Monné) > v2: > - use 'XEN_SYSCTL_PSR_MBA_LINEAR' to set MBA feature HW info. > (suggested by Chao Peng) > v1: > - sort 'PSR_INFO_IDX_' macros as feature. > (suggested by Chao Peng) > - rename 'PSR_INFO_IDX_MBA_LINEAR' to 'PSR_INFO_IDX_MBA_FLAG'. > - rename 'linear' in 'struct mba_info' to 'flags' for future extension. > (suggested by Chao Peng) > --- > xen/arch/x86/psr.c | 15 ++++++++++++++- > xen/arch/x86/sysctl.c | 21 ++++++++++++++++++++- > xen/include/asm-x86/psr.h | 2 ++ > xen/include/public/sysctl.h | 8 ++++++++ > 4 files changed, 44 insertions(+), 2 deletions(-) > > diff --git a/xen/arch/x86/psr.c b/xen/arch/x86/psr.c > index e2f8fd0..1d0a215 100644 > --- a/xen/arch/x86/psr.c > +++ b/xen/arch/x86/psr.c > @@ -263,6 +263,10 @@ static enum psr_feat_type psr_type_to_feat_type(enum > psr_type type) > feat_type = FEAT_TYPE_L2_CAT; > break; > > + case PSR_TYPE_MBA_THRTL: > + feat_type = FEAT_TYPE_MBA; > + break; > + > default: > ASSERT_UNREACHABLE(); > } > @@ -486,7 +490,16 @@ static const struct feat_props l2_cat_props = { > static bool mba_get_feat_info(const struct feat_node *feat, > uint32_t data[], unsigned int array_len) > { > - return false; > + if ( array_len != PSR_INFO_ARRAY_SIZE ) Should this be an ASSERT maybe? I don't see how array_len can be != PSR_INFO_ARRAY_SIZE. > + return false; > + > + data[PSR_INFO_IDX_COS_MAX] = feat->cos_max; > + data[PSR_INFO_IDX_MBA_THRTL_MAX] = feat->mba.thrtl_max; > + > + if ( feat->mba.linear ) > + data[PSR_INFO_IDX_MBA_FLAG] |= XEN_SYSCTL_PSR_MBA_LINEAR; > + > + return true; > } > > static void mba_write_msr(unsigned int cos, uint32_t val, > diff --git a/xen/arch/x86/sysctl.c b/xen/arch/x86/sysctl.c > index 9dee163..b2f8efa 100644 > --- a/xen/arch/x86/sysctl.c > +++ b/xen/arch/x86/sysctl.c > @@ -174,7 +174,7 @@ long arch_do_sysctl( > case XEN_SYSCTL_psr_alloc: > switch ( sysctl->u.psr_alloc.cmd ) > { > - uint32_t data[PSR_INFO_ARRAY_SIZE]; > + uint32_t data[PSR_INFO_ARRAY_SIZE] = {0}; I would rather do "{ 0 };" or "{ };" (note the spaces around the 0). Thanks, Roger. _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx https://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |