[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] minimum Python version

Jan Beulich writes ("minimum Python version"):
> for quite a while (apparently as of Marek's series in February) I've
> been seeing
> xen/lowlevel/xc/xc.c: In function ‘pyxc_dom_extract_cpuid’:
> xen/lowlevel/xc/xc.c:692:13: error: implicit declaration of function 
> ‘PyBytes_AS_STRING’ [-Werror=implicit-function-declaration]

"PyBytes_AS_STRING" is a compatibility alias to help porting to Python
3.  They are provided in Python 2.6.0 and later.


Python 2.6.0 was released on 1st October 2008.  In a week and a half's
time that will be 10 years ago.

Under the circumstances we should clearly keep the Python-3-compatible

> on an older system having Python 2.4 on it. The minimum version
> configure checks for appears to be 2.3, matching up with what
> ./README says. Since the Python bindings aren't something one
> absolutely needs (afaict), wouldn't it be reasonable to check for
> a suitable version and if that fails simply disable their building
> (which currently is unconditional)? What I'd like to avoid is ending
> up with being unable to build the tools on that system - I know
> it's rather old, but there's a reason I'd like to keep it (including its
> old distro level).

I would welcome a patch to change the minimum python version to 2.6.
I would also welcome a patch to make a too-old python version disable
the python build rather than causing the whole build to break.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.