[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 1/7] x86/mm: Improvements to PV l1e mapping helpers

On Tue, Sep 12, 2017 at 01:14:40PM +0100, Andrew Cooper wrote:
> Drop guest_unmap_l1e() and use unmap_domain_page() directly.  This will
> simplify future cleanup.  Rename guest_map_l1e() to map_guest_l1e() to closer
> match the mapping nomenclature.
> Switch map_guest_l1e() to using mfn_t.  Correct the comment to indicate that
> it takes a linear address (not a virtual address), and correct the parameter
> name.
> No functional change.
> Signed-off-by: Andrew Cooper <andrew.cooper3@xxxxxxxxxx>

Reviewed-by: Wei Liu <wei.liu2@xxxxxxxxxx>

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.