[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v2 03/15] x86: rename 'cbm_type' to 'psr_val_type' to make it general

On 17-08-29 13:15:24, Roger Pau Monn� wrote:
> On Thu, Aug 24, 2017 at 09:14:37AM +0800, Yi Sun wrote:
> > This patch renames 'cbm_type' to 'psr_val_type' to make it be general.
> I'm unsure whether the '_val_' is really needed here. AFAICT it
> doesn't add any meaningful information to the define itself, and only
> makes it longer. Apart from that it looks fine.
The 'cbm_type' means the CAT value (CBM) type. As MBA value type is throttle,
I want to rename 'cbm_type' to a generic value type. Because there are many
'psr' starting names, to make it clear that this structure is for value type,
I name it 'psr_val_type'.

If you still think it is not appropriate, I will remove '_val'.

> Roger.

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.