[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 4/5] x86/pv: Simplify access to the LDT/GDT ptes

On Tue, Aug 29, 2017 at 12:19:15PM +0100, Andrew Cooper wrote:
> Rename gdt_ldt_ptes() to pv_gdt_ptes() and drop the domain parameter, as it is
> incorrect to use the helper with d != v->domain.
> Introduce pv_ldt_ptes() to abstract away the fact that the LDT mapping is 16
> slots after the GDT, and adjust the callers accordingly.
> Signed-off-by: Andrew Cooper <andrew.cooper3@xxxxxxxxxx>

Reviewed-by: Wei Liu <wei.liu2@xxxxxxxxxx>

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.