[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH 1/2] x86/page: Rename PAGE_HYPERVISOR_NOCACHE to PAGE_HYPERVISOR_UCMINUS
>>> On 14.08.17 at 12:57, <andrew.cooper3@xxxxxxxxxx> wrote: > --- a/xen/arch/x86/boot/x86_64.S > +++ b/xen/arch/x86/boot/x86_64.S > @@ -92,7 +92,7 @@ l1_identmap: > .rept L1_PAGETABLE_ENTRIES > /* VGA hole (0xa0000-0xc0000) should be mapped UC. */ > .if pfn >= 0xa0 && pfn < 0xc0 > - .quad (pfn << PAGE_SHIFT) | PAGE_HYPERVISOR_NOCACHE | MAP_SMALL_PAGES > + .quad (pfn << PAGE_SHIFT) | PAGE_HYPERVISOR_UCMINUS | MAP_SMALL_PAGES Mind making the comment say UC- at once? > --- a/xen/include/asm-arm/mm.h > +++ b/xen/include/asm-arm/mm.h > @@ -176,7 +176,7 @@ void __iomem *ioremap_attr(paddr_t start, size_t len, > unsigned attributes); > > static inline void __iomem *ioremap_nocache(paddr_t start, size_t len) > { > - return ioremap_attr(start, len, PAGE_HYPERVISOR_NOCACHE); > + return ioremap_attr(start, len, PAGE_HYPERVISOR_UCMINUS); > } Is UC- really an arch-independent term? I wouldn't mind switching the x86 side, but I don't think ARM should be changed. Oh, and now I notice your follow-up mail ... So preferably with the comment adjustment above Reviewed-by: Jan Beulich <jbeulich@xxxxxxxx> Jan _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx https://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |