[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [RFC v2 10/12] tools: implemet new get value interface suitable for all psr allocation features.
On 17-07-31 15:30:16, Wei Liu wrote: > On Thu, Jul 20, 2017 at 04:49:11PM +0800, Yi Sun wrote: > > This patch implements a new get value interface in tools suitable for all > > psr > > allocation features and the whole flow. It also enables MBA support in tools > > to get MBA value. > > This suggests this patch can be at least broken into two? > > > > > Signed-off-by: Yi Sun <yi.y.sun@xxxxxxxxxxxxxxx> > > --- > > tools/libxc/include/xenctrl.h | 13 +- > > tools/libxc/xc_psr.c | 11 +- > > tools/libxl/libxl_psr.c | 61 ++++++---- > > tools/xl/xl.h | 3 + > > tools/xl/xl_cmdtable.c | 9 +- > > tools/xl/xl_psr.c | 275 > > ++++++++++++++++++++++++++---------------- > > 6 files changed, 236 insertions(+), 136 deletions(-) > > > > diff --git a/tools/libxc/include/xenctrl.h b/tools/libxc/include/xenctrl.h > > index 0b0ec31..def18f5 100644 > > --- a/tools/libxc/include/xenctrl.h > > +++ b/tools/libxc/include/xenctrl.h > > @@ -2452,13 +2452,14 @@ enum xc_psr_cmt_type { > > }; > > typedef enum xc_psr_cmt_type xc_psr_cmt_type; > > > > -enum xc_psr_cat_type { > > +enum xc_psr_val_type { > > XC_PSR_CAT_L3_CBM = 1, > > XC_PSR_CAT_L3_CBM_CODE = 2, > > XC_PSR_CAT_L3_CBM_DATA = 3, > > XC_PSR_CAT_L2_CBM = 4, > > + XC_PSR_MBA_THRTL = 5, > > }; > > -typedef enum xc_psr_cat_type xc_psr_cat_type; > > +typedef enum xc_psr_val_type xc_psr_val_type; > > Changing the name of the type should be done in a separate patch. > > The rest of this patch mixes renaming and functional change which is > rather difficult to review I'm afraid. > Thanks! I will split the patch to two, one for type renaming, the other for functionality. BRs, Sun Yi _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx https://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |