[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [RFC PATCH v3 04/24] x86: NUMA: Rename and sanitize memnode shift code

On Tue, Jul 18, 2017 at 05:11:26PM +0530, vijay.kilari@xxxxxxxxx wrote:
> From: Vijaya Kumar K <Vijaya.Kumar@xxxxxxxxxx>
> memnode_shift variable is changed from int to unsigned int.
> With this change, compute_memnode_shift() returns error value
> instead of returning shift value. The memnode_shift is updated inside
> compute_memnode_shift().
> Also, following changes are made
>   - Rename compute_hash_shift to compute_memnode_shift
>   - Update int to unsigned int for params in extract_lsb_from_nodes()
>   - Return values of populate_memnodemap() is changed
> Signed-off-by: Vijaya Kumar K <Vijaya.Kumar@xxxxxxxxxx>

Reviewed-by: Wei Liu <wei.liu2@xxxxxxxxxx>

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.