[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v6 10/14] arm/guest_access: Rename vgic_access_guest_memory

On 18/07/17 09:42, Sergej Proskurin wrote:
Hi Julien,

On 07/17/2017 05:43 PM, Julien Grall wrote:
Hi Sergej,

On 06/07/17 12:50, Sergej Proskurin wrote:
This commit renames the function vgic_access_guest_memory to
access_guest_memory_by_ipa. As the function name suggests, the functions
expects an ipa as argument. Thus, to make the function's purpose more


clearly, we have also renamed the argument gva into ipa. All invocations

The argument is call gpa not gva. gpa stands for "Guest Physical
Address" which is the name commonly used in Xen. IPA is the ARM naming.

Thanks. I have mistyped that one.

So I am not convinced of the usefulness of this rename.

I Agree. As you have suggested to use access_guest_memory_by_ipa as
function name, I just wanted to be consistent. How about renaming the
function to access_guest_memory_by_gpa instead? Then, we would remain
consistent with Xen's naming conventions also on the function level.

Either name is fine by me. I just don't see any reason to rename GPA to IPA as both have the same meaning.


Julien Grall

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.