[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] 4.9rc4: Cannot build with higher than -j4 - was: linux.c:27:28: fatal error: xen/sys/evtchn.h: No such file or directory

Hi George,

CC Ian and Wei for feedback on the error.

On 15/05/17 14:04, George Dunlap wrote:
On Sun, May 14, 2017 at 10:50 AM, Steven Haigh <netwiz@xxxxxxxxx> wrote:
On 10/05/17 23:02, Steven Haigh wrote:
On 10/05/17 01:20, M A Young wrote:
On Tue, 9 May 2017, Steven Haigh wrote:

I'm trying to use the same build procedure I had for working correctly
for Xen 4.7 & 4.8.1 - but am coming across this error:

gcc  -DPIC -m64 -DBUILD_ID -fno-strict-aliasing -std=gnu99 -Wall
-Wstrict-prototypes -Wdeclaration-after-statement
-Wno-unused-but-set-variable -Wno-unused-local-typedefs   -g3 -O0
-fno-omit-frame-pointer -D__XEN_INTERFACE_VERSION__=__XE
-D_LARGEFILE64_SOURCE   -Werror -Wmissing-prototypes -I./include
 -fPIC -c -o linux.opic linux.c
mv headers.chk.new headers.chk
linux.c:27:28: fatal error: xen/sys/evtchn.h: No such file or directory
 #include <xen/sys/evtchn.h>
compilation terminated.
linux.c:27:28: fatal error: xen/sys/evtchn.h: No such file or directory
 #include <xen/sys/evtchn.h>
compilation terminated.

Any clues as to what to start pulling apart that changed between 4.8.1
and 4.9.0-rc4 that could cause this?

It worked for me in a test build, eg. see one of the builds at

Ok, after lots of debugging, when I run 'make dist', I usually use the
macro for smp building, so I end up with:
      make %{?_smp_mflags} dist

It seems this is hit and miss as to it actually working.

I have had a 100% success rate (but slow builds) with:
      make dist

Trying with 'make -j4 dist' seems to work the couple of times I've tried it.

This seems to be a new problem that I haven't come across before in 4.4,
4.5, 4.6, 4.7 or my initial 4.8.1 builds - so its new to 4.9.0 rc's.

The consensus on #xen seems to be that there is a race between libs &
include - and that these are supposed to be built in sequence and not

I'm a little over my depth now - as I assume this heads into Makefile land.

If it helps, there is a full build log available at:

I've committed my current progress in my git tree:

Right now, we're looking at lines 304 / 305 of SPECS/xen49.spec

Just wanted to give this a nudge. It seems if you build with above -j4
(on a machine with suitable number of cores), the build will fail. This
is a degradation from any version previous to 4.9.


Probably something we should put on your list as a release blocker.

I think you are right. Added in the list.


Julien Grall

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.