[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH 04/10] xen/arm: vpl011: Provide a knob in libxl to enable/disable pl011 emulation
On Thu, Apr 13, 2017 at 01:49:51PM +0530, Bhupinder Thakur wrote: > Hi Wei, > > >> diff --git a/tools/libxl/libxl_types.idl b/tools/libxl/libxl_types.idl > >> index a612d1f..fe7f795 100644 > >> --- a/tools/libxl/libxl_types.idl > >> +++ b/tools/libxl/libxl_types.idl > >> @@ -105,6 +105,7 @@ libxl_console_type = Enumeration("console_type", [ > >> (0, "UNKNOWN"), > >> (1, "SERIAL"), > >> (2, "PV"), > >> + (3, "VCON"), > >> ]) > >> > > > > You need to add a LIBXL_HAVE macro to libxl.h. > > I will add this macro. I am trying to understand the use of these > macros. Are the applications which are building against a particular > libxl version supposed to check this flag before using this feature? > Yes. Think about a new application that is built against an older version of libxl source code that doesn't have this flag. It can use this flag to check if such feature is available. > > > >> libxl_disk_format = Enumeration("disk_format", [ @@ -460,6 +461,7 > >> @@ libxl_domain_build_info = Struct("domain_build_info",[ > >> ("disable_migrate", libxl_defbool), ("cpuid", > >> libxl_cpuid_policy_list), ("blkdev_start", string), + > >> ("enable_pl011", libxl_defbool), > >> > >> ("vnuma_nodes", Array(libxl_vnode_info, "num_vnuma_nodes")), > >> > >> diff --git a/tools/libxl/xl_cmdimpl.c b/tools/libxl/xl_cmdimpl.c > >> index 358757f..4f4d4e6 100644 --- a/tools/libxl/xl_cmdimpl.c +++ > >> b/tools/libxl/xl_cmdimpl.c @@ -1433,6 +1433,8 @@ static void > >> parse_config_data(const char *config_source, if (!xlu_cfg_get_long > >> (config, "maxvcpus", &l, 0)) b_info->max_vcpus = l; > >> > >> + xlu_cfg_get_defbool(config, "pl011", &b_info->enable_pl011, > >> 0); + > > > > I'm not very keen on having "pl011" because it is ARM specific. > I will rename it to vconsole, which I am using through out the libxl > code now. Before you go away and change your code, we need to discuss this a bit. Since there is no "console" option in xl, I think using just "console" should be fine. And then user can specify "console=pl011" in their config file. There will also need to be changes in the libxl idl struct. If you really want to use enable_pl011 (I would suggest to just use pl011), it should be part of the arm specific sub-struct in build_info. Please also wait a bit for Ian to express his preference for the config option etc. Wei. _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx https://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |