[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH RESEND v5 05/24] x86: refactor psr: implement Domain init/free and schedule flows.



On Thu, Jan 19, 2017 at 02:01:07PM +0800, Yi Sun wrote:
> This patch implements the Domain init/free and schedule flows.
> 
> Signed-off-by: Yi Sun <yi.y.sun@xxxxxxxxxxxxxxx>
> ---
> v5:
>     - define macro 'PSR_ASSOC_REG_POS' to replace integer 32.
>     - rename 'l3_cat_get_max_cos_max' to 'l3_cat_get_cos_max'.
>     - modify variables names to make them better, e.g. 'feat_tmp' to 'feat'.
> ---
>  xen/arch/x86/psr.c | 62 
> +++++++++++++++++++++++++++++++++++++++++++++++++++++-
>  1 file changed, 61 insertions(+), 1 deletion(-)
> 
> diff --git a/xen/arch/x86/psr.c b/xen/arch/x86/psr.c
> index e9dc07a..7f06235 100644
> --- a/xen/arch/x86/psr.c
> +++ b/xen/arch/x86/psr.c
> @@ -50,6 +50,8 @@
>   */
>  #define MAX_COS_REG_CNT  128
>  
> +#define PSR_ASSOC_REG_POS 32

Perhaps PSR_ASSOC_REG_SHIFT ?

Otherwise: Reviewed-by: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>

_______________________________________________
Xen-devel mailing list
Xen-devel@xxxxxxxxxxxxx
https://lists.xen.org/xen-devel

 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.