[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH 4/4] xen/public: arm: rework the macro set_xen_guest_handle_raw
>>> On 02.11.15 at 16:55, <stefano.stabellini@xxxxxxxxxxxxx> wrote: > Honestly I would be OK with having a typeof in the public headers to > avoid this code, which is much harder to follow. Why don't we do > something like the following: > > > diff --git a/xen/include/public/arch-arm.h b/xen/include/public/arch-arm.h > index 9a96401..e676ffb 100644 > --- a/xen/include/public/arch-arm.h > +++ b/xen/include/public/arch-arm.h > @@ -189,11 +189,12 @@ > #define __XEN_GUEST_HANDLE(name) __guest_handle_64_ ## name > #define XEN_GUEST_HANDLE(name) __XEN_GUEST_HANDLE(name) > #define XEN_GUEST_HANDLE_PARAM(name) __guest_handle_ ## name > +#define barrier() __asm__ __volatile__("": : :"memory") > #define set_xen_guest_handle_raw(hnd, val) \ > do { \ > - typeof(&(hnd)) _sxghr_tmp = &(hnd); \ > - _sxghr_tmp->q = 0; \ > - _sxghr_tmp->p = val; \ > + *((uint64_aligned_t *)&(hnd)) = 0; \ > + barrier(); \ > + (hnd).p = val; \ > } while ( 0 ) Because __asm__ again is an extension? Jan _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx http://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |