[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 2/3] x86: drop is_pv_32on64_domain()



On Tue, 2015-06-23 at 16:19 +0100, Jan Beulich wrote:
> ... as being identical to is_pv_32bit_domain() after the x86-32
> removal.
> 
> In a few cases this includes no longer open-coding is_pv_32bit_vcpu().
> 
> Signed-off-by: Jan Beulich <jbeulich@xxxxxxxx>

Given that the common impact is effectively x86-only due to the ifdefs
(CONFIG_COMPAT is effectively x86 IMHO) I don't think you really need it
but:

Acked-by: Ian Campbell <ian.campbell@xxxxxxxxxx>

> --- a/xen/common/kexec.c
> +++ b/xen/common/kexec.c
> @@ -872,7 +872,7 @@ static int kexec_load_slot(struct kexec_
>  static uint16_t kexec_load_v1_arch(void)
>  {
>  #ifdef CONFIG_X86
> -    return is_pv_32on64_domain(hardware_domain) ? EM_386 : EM_X86_64;
> +    return is_pv_32bit_domain(hardware_domain) ? EM_386 : EM_X86_64;
>  #else
>      return EM_NONE;
>  #endif
> --- a/xen/common/xenoprof.c
> +++ b/xen/common/xenoprof.c
> @@ -219,7 +219,7 @@ static int alloc_xenoprof_struct(
>      bufsize = sizeof(struct xenoprof_buf);
>      i = sizeof(struct event_log);
>  #ifdef CONFIG_COMPAT
> -    d->xenoprof->is_compat = is_pv_32on64_domain(is_passive ? 
> hardware_domain : d);
> +    d->xenoprof->is_compat = is_pv_32bit_domain(is_passive ? hardware_domain 
> : d);
>      if ( XENOPROF_COMPAT(d->xenoprof) )
>      {
>          bufsize = sizeof(struct compat_oprof_buf);



_______________________________________________
Xen-devel mailing list
Xen-devel@xxxxxxxxxxxxx
http://lists.xen.org/xen-devel


 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.