[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH OSSTEST v3 12/11] toolstack/libvirt: install libnl-3-200 on Jessie
Wei Liu writes ("[PATCH OSSTEST v3 12/11] toolstack/libvirt: install libnl-3-200 on Jessie"): > Signed-off-by: Wei Liu <wei.liu2@xxxxxxxxxx> ... > diff --git a/Osstest/Toolstack/libvirt.pm b/Osstest/Toolstack/libvirt.pm > index e7f4860..c71f88a 100644 > --- a/Osstest/Toolstack/libvirt.pm > +++ b/Osstest/Toolstack/libvirt.pm > @@ -24,11 +24,15 @@ use Osstest::TestSupport; > > sub new { > my ($class, $ho, $methname,$asset) = @_; > + my @extra_packages = qw(libavahi-client3); > + my $nl_lib = "libnl-3-200"; > + $nl_lib = "libnl1" if ($ho->{Suite} =~ m/wheezy/); > + push(@extra_packages, $nl_lib); > return bless { Name => "libvirt", > Host => $ho, > NewDaemons => [qw(libvirtd)], > Dom0MemFixed => 1, > - ExtraPackages => [qw(libnl1 libavahi-client3)], > + ExtraPackages => [@extra_packages], It would be more normal to write \@extra_packages rather than [@extra_packages] unless you actually need to make a copy of the array. (I don't care about this for efficiency, but rather for readability: writing [@extra_packages] carries an implication that something might edit either @extra_packages or ExtraPackages afterwards. Ian. _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx http://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |