[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH] introduce and used relaxed cpumask operations
At 14:10 +0000 on 21 Jan (1421845837), Jan Beulich wrote: > >>> On 21.01.15 at 13:21, <andrew.cooper3@xxxxxxxxxx> wrote: > > On 19/01/15 15:58, Jan Beulich wrote: > >> --- a/xen/common/core_parking.c > >> +++ b/xen/common/core_parking.c > >> @@ -75,11 +75,10 @@ static unsigned int core_parking_perform > >> if ( core_weight < core_tmp ) > >> { > >> core_weight = core_tmp; > >> - cpumask_clear(&core_candidate_map); > >> - cpumask_set_cpu(cpu, &core_candidate_map); > >> + cpumask_copy(&core_candidate_map, cpumask_of(cpu)); > > > > It is probably worth mentioning changes like this in the commit message, > > as they are slightly more than just a simple removal of the lock prefix. > > Added. > > >> +static inline void __cpumask_clr_cpu(int cpu, cpumask_t *dstp) > >> +{ > >> + __clear_bit(cpumask_check(cpu), dstp->bits); > >> +} > >> + > > > > While I can appreciate the want for a shorter function name, I feel that > > consistency with its locked alternative is more important. > > I sort of expected a comment to that effect, but decided to use the > shorter names nevertheless. Let's see what others, namely the REST > maintainers, say. FWIW, I prefer consistent naming (i.e. __cpumask_clear_cpu()). Cheers, Tim. _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx http://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |