[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH for 4.6 07/13] xen: Introduce a generic way to describe device

On 18/12/2014 16:02, Jan Beulich wrote:
On 18.12.14 at 16:56, <julien.grall@xxxxxxxxxx> wrote:
On 17/12/2014 17:17, Jan Beulich wrote:
Aliasing device and pci_dev for x86 would yield similar clarity afaict.

To be sure, by aliasing you mean creating a typedef?

For x86:
typedef struct pci_dev device_t;

And for ARM:
typedef struct device device_t;

Yes, I think that's the only reasonable thing. Using a #define would
seem ugly no matter which direction you did it.

Right. We have some place where device and pci_device are used as variable. It would have introduced some strange compilation error.

I will go ahead with this solution.


Julien Grall

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.