[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] gdbsx - xg_attach:Unable to pause domain:1; failed to attach to domain:1 errno:13

On Tue, 26 Aug 2014 02:14:30 +0000
Pete Delaney <pdelaney@xxxxxxxxxxxxxxx> wrote:

> Hi Mukesh:
> I tried your gdbsx stub but hit a couple errors.
> I didn't find an explanation with google; nor on the xen-devel
> mailing list yet. Thought I'd ask ya.
> I installed Ubuntu-14.04 Server with OpenXenManager on my Xenon
> workstation and have A Xenon blade also with Ubunto-14.04 and
> OpenXen. Seems to run about the same on both Machines.
> This afternoon I pulled the Xen source with git from xenbits.xen.org
> and build it.
> The version of gdbsx that I built on my workstation is having
> problems attaching to Domain-0. I tried this on the host. Do I need
> to create a shell to a Domain-0 instance or something?

gdbsx runs on dom0 and attaches to a domU.

>     root@piet-openxen:~# ./gdbsx -c 1 64
>     ERROR:xg_attach:Unable to pause domain:1
>     ERROR: failed to attach to domain:1 errno:13
> [Permission Denied]

Hmm... I just tried and it worked for me, so things are ok it seems
on latest xen/linux. The errno EPERM indicates something might not
be properly setup. Are you able to run other xen commands like xl list,
etc?  I see you are running as root, are you running gdbsx on dom0? 


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.