[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH RFC V4 2/5] xen: Optimize introspection access to guest state

>>> On 04.08.14 at 13:30, <rcojocaru@xxxxxxxxxxxxxxx> wrote:
> Changes since V3:
>  - Changed the name of VCPU variables referring to the current
>    VCPU to "curr".
>  - Renamed "mem_event_regs" to "x86_mem_event_regs" to make it
>    explicit.

That's a step in the right direction, but perhaps not enough. I realize
the whole header doesn't meet the requirements we nowadays put
on public ones, but let's at least not make it worse. I.e. in the case
at hand either out a xen_ prefix as the very first thing (making this
structure's name not match anything else in that header) or as a
compromise stay at least with the mem_event_ prefix, i.e. name it

Furthermore as typedef-ed name with out _t suffix is kind of
unusual. I'm not sure if it was in the context of this series that
someone suggested that the _t collides with the C standard. If
that's really the case, and since you don't need a handle for the
type, please just avoid the typedef (and drop the _st suffix from
the structure tag at once).


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.