[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 1/4] PCI: introduce helper functions for device flag operation

On 2014/7/29 10:31, Alex Williamson wrote:
On Tue, 2014-07-29 at 09:53 +0800, ethan zhao wrote:
On 2014/7/29 5:00, Alex Williamson wrote:
On Wed, 2014-07-23 at 00:19 +0800, Ethan Zhao wrote:
This patch introduced three helper functions to hide direct
device flag operation.

void pci_set_dev_assigned(struct pci_dev *pdev);
void pci_set_dev_deassigned(struct pci_dev *pdev);
bool pci_is_dev_assigned(struct pci_dev *pdev);

Signed-off-by: Ethan Zhao <ethan.zhao@xxxxxxxxxx>
   include/linux/pci.h |   13 +++++++++++++
   1 files changed, 13 insertions(+), 0 deletions(-)

diff --git a/include/linux/pci.h b/include/linux/pci.h
index aab57b4..5f6f8fa 100644
--- a/include/linux/pci.h
+++ b/include/linux/pci.h
@@ -1129,6 +1129,19 @@ resource_size_t pcibios_window_alignment(struct pci_bus 
int pci_set_vga_state(struct pci_dev *pdev, bool decode,
                      unsigned int command_bits, u32 flags);
+/* helper functions for operation of device flag */
+static inline void pci_set_dev_assigned(struct pci_dev *pdev)
+       pdev->dev_flags |= PCI_DEV_FLAGS_ASSIGNED;
+static inline void pci_set_dev_deassigned(struct pci_dev *pdev)
+       pdev->dev_flags &= ~PCI_DEV_FLAGS_ASSIGNED;
I think pci_clear_dev_assigned() would make more sense, we're not
setting a flag named DEASSIGNED.
    Though it is a flag operation now, may not later, we define it
because we want to hide the internal operation.
    'set' to 'deassigned'  status is enough. So I would like keep it.
I disagree, the opposite of a 'set' is a 'clear', or at least an
'unset'.  Using bit-ops-like terminology doesn't lock us into an
implementation.  As written, this could just as easily be setting two
different variables.
 So there are two pairs of opposite:

 set assigned ---> unset assigned
 set assigned ---> set deassigned

Here you prefer the 'verb' set /unset, and I prefer the 'adj.' assigned / deassigned.

Do they really have different meaning or make confusion ? I don't think so.


+static inline bool pci_is_dev_assigned(struct pci_dev *pdev)
+       return pdev->dev_flags & PCI_DEV_FLAGS_ASSIGNED ? true : false;
The ternary operation isn't necessary.  Thanks,

    return pdev->dev_flags & PCI_DEV_FLAGS_ASSIGNED

    is enough.


   /* kmem_cache style wrapper around pci_alloc_consistent() */
#include <linux/pci-dma.h>

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.