[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Unsolved: proprietary RAID driver and Xen dom0 kernels

Greetings to all-

Just to attract developers' attention:

I used CentOS 6.5 + Xen 4.2.3 (from Xen4CentOS project). Everything worked fine on HP ProLiant DL360p Gen8 (both internal RAID and SAN drivers built into kernel 2.6.32+).
Then I had to move all virtual machines to another hardware, DL380e Gen8.

Problem: hpvsa RAID driver provided by HP for RHEL6 (compiled for kernels 2.6.32-131.0.15 to 2.6.32-431).
Any mainline kernel picks it up and all works perfectly but I failed to get it workable with Xen Dom0 kernels.

1. make link to hpvsa.ko in /lib/modules/<version>/weak-updates (exactly as with mainline kernels)
2. depmod -a <version>
3. mkinitrd -f initramfs-<version>.img <version>

As a result module hpvsa.ko gets into image, modules.dep and modules.alias contain references to it.
Then kernel panic while boot.

Tested kernels:
- 3.10.43-11.el6.centos.alt.x86-64 from Xen4CentOS repository;
- 2.6.32-131.21.1.el6.xendom0.x86_64 from http://xenbits.xen.org/people/mayoung/testing/.

I dug a little deeper and discovered that the problem is too fundamental: different compilation options. Dracut debug shell let me see the messages preceding kernel panic, literally:
"hpvsa: disagrees about version of symbol module_layout"

Tried to tamper hpvsa.ko with hex editor. No result. First intervention was easy but next I faced the bunch of tens of similar messages.
As the driver source is unavailable, I couldn't solve the problem.

Hope this info may somehow help the project.

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.