[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Enabling kdump on SuSE 11 SP3 Xen resulting in error

Ok. Thanks. I'll engage our internal support channel with SuSE. However, I see these docs on novell site:

  1. Note:  As of 12/01/08 makedumpfile currently only supports the "ELF" format and a dumplevel setting of "0".  Check/etc/sysconfig/kdump file and verify KDUMP_DUMPLEVEL="0" and KDUMP_DUMPFORMAT="ELF".

It seems it still holds true with SuSE 11 SP3.


On Tue, Feb 4, 2014 at 1:03 AM, Jan Beulich <JBeulich@xxxxxxxx> wrote:
>>> On 03.02.14 at 23:17, Saurabh Mishra <saurabh.globe@xxxxxxxxx> wrote:
> I'm trying to enable kdump on SuSE 11 SP3 with Xen configuration on our
> cards but having problem.

In general issues like this are not to be dealt with here, but by
SUSE support.

> If I don't specify KDUMP_DUMPFORMAT=ELF, it does not work and does not try
> to take vmcore.
> If I specify KDUMP_DUMPLEVEL=0, then it does work but it takes very long
> time. I tried using KDUMP_DUMPLEVEL=30 or 10 but it complaint that there is
> not much space even though I've about 4.8 GB space with crashkernel
> configured as 256M@64M.

If the dump kernel comes up and the dumping takes lone (or you
have other issues with dumping), then this is the wrong forum in
any case: Xen is no longer involved in this operation (the dump
kernel runs on bare hardware).

> Here's output from /proc/cmdline :-
> lc-1:~ # cat /proc/cmdline
> crashkernel=256M@64M root=/dev/sda5 earlyprintk=serial,ttyS0,115200n8
> resume=/dev/sda5 splash=silent showopts  console=ttyS0,115200n8
> lc-1:~ # grep crashkernel /boot/efi/efi/SuSE/xen.cfg
> kernel=vmlinuz-3.0.93-0.8-xen  crashkernel=256M@64M root=/dev/sda5
> earlyprintk=serial,ttyS0,115200n8 resume=/dev/sda5 splash=silent showopts
>  console=ttyS0,115200n8
> options=console=com1 com1=115200 dom0_mem=8192m iommu=1,sharept
> extra_guest_irqs=80 reboot=efi crashkernel=256M@64M

Now this makes things really interesting: Dumping in a UEFI
environment is generally unsupported (this is actually being worked
on upstream afaik). Whether the dump kernel can come up properly
at all depends on the specific characteristics of your firmware
implementation. It could in particular be that the dump kernel has
no way of finding ACPI tables, and hence setup of interrupts and
alike may not work as expected/needed.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.