[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [Qemu-devel] Qxl problem with xen domU, is xen spice and/or qemu bugs?

Il 01/10/2013 14:52, Fabio Fantoni ha scritto:
Il 27/09/2013 15:53, Fabio Fantoni ha scritto:
Il 27/09/2013 10:51, Gerd Hoffmann ha scritto:

#2 When using f19 try without X11 first.  You should have a working
     framebuffer console on qxldrmfb before trying to get X11 going.
I tried on Fedora19 minimal installation and with qxl the text console
is working and lsmod show also qxl.
Good, so the kernel driver is running fine.

Is this your intended?

#3 qxl has a bunch of tracepoints. Enable them, then compare xen
results with kvm/tcg results to see where things start going wrong.
I enabled qxl debug with these qemu paramters:
-global qxl-vga.debug=1 -global qxl-vga.guestdebug=20
debug=1 doesn't do much, most is in tracepoints these days. I'm using
the stderr tracer most of the time (enable it using configure). Then
you can turn on qxl_* either in monitor (trace-events command) or via
-trace events=<file-with-event-names>.

Thanks for reply, I used trace of qxl_* instead of -global debug options (is it right or must I maintain also global qxl debug option?).
On attachment the new qemu log of windows 7 test with qxl vga.
The test was made as for below:
I tried also W7 domU on xen with spice-guest-tools-0.65.exe and qxl: domU starts, loads correctly the DE, vdagent and mouse are both working, but screen refreshing is very lagging (also only open of start menu).

Can you check the log to see if there are strange things to fix also on spice and/or qemu?
Thanks for any reply.

I tried to test Fedora19 on debian sid kvm host same qemu version
(1.6) on both sides but with qxl fails to start the DE, also in
fallback mode. Probably there are also regression on qemu and/or spice
about qxl.
I'm not aware of any regressions.
I'd suggest to try latest spice-server release.

I double checked and is already to latest version:

After I updated Fedora19 vm on kvm, it works with qxl.

I compared xen and kvm logs and the only relevant difference that I found is this line on /var/log/messages of xen domU:
ioremap error for 0xfc001000-0xfc002000, requested 0x10, got 0x0
I attached all messages and Xorg logs for both xen and kvm (Fedora19) tests with qxl.

And about xen hypervisor logs (with xl dmesg) the only difference between stdvga and qxl (same domU) is that qxl log has 3 "pci dev bar" more. Full logs on attachments.

Thanks for any reply.


I made other tests with qxl using xen_platform_pci=0 (now that it is functioning with qemu upstream too). On a W7 domU the main problem with performances with qxl drivers seems to be solved but unfortunately I didn't find a way to have both qxl and xen gplpv working.
On a Saucy domU (ubuntu 13.10) with this kernel patch applied (see below):
the black screen and X process to 100% persists.
Attached the xorg log with a backtrace in it.
Anyone on this please?

Thanks for any reply.

Attachment: Xorg.0.log
Description: Text document

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.