[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH] xen/pvhvm: If xen_platform_pci=0 is set don't blow up.
On Wed, 4 Dec 2013, Ian Campbell wrote: > On Wed, 2013-12-04 at 10:51 +0000, Stefano Stabellini wrote: > > On Wed, 4 Dec 2013, Ian Campbell wrote: > > > > +bool xen_has_pv_devices(void) > > > > +{ > > > > + if (!xen_domain()) > > > > + return false; > > > > + > > > > + if (xen_hvm_domain()) { > > > > + /* User requested no unplug, so no PV drivers. */ > > > > + if (xen_emul_unplug & XEN_UNPLUG_NEVER) > > > > + return false; > > > > > > I think you need > > > if (xen_emul_unpug & XEN_UNPLUG_UNNECESSARY) > > > return true; > > > don't you? > > > > XEN_UNPLUG_UNNECESSARY was introduced to enable the platform PCI device > > even if it didn't respond properly to the unplug protocol. > > The corresponding parameter is called "unnecessary" because if you pass > > it to the kernel you mean that it is unnecessary to unplug the emulated > > devices but you can use the pv devices anyway. > > > > So no, we shouldn't check for XEN_UNPLUG_UNNECESSARY here. > > Oh, we will eventually fall through to the return true, so it does > actually work out OK. > > I'd still be in favour of handling each option explicitly, for clarity. > Which means checking for XEN_UNPLUG_UNNECESSARY. I think is wrong to check for any xen_emul_unpug options in this function. The xen_emul_unpug options should be used to set the right value of xen_platform_pci_unplug. (See my other reply.) > > > > + /* And user has xen_platform_pci=0 set in guest config > > > > as > > > > + * driver did not modify the value. */ > > > > + if (!xen_platform_pci_unplug) > > > > + return false; > > I assume this check doesn't trigger if unnecessary has been specified? right _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx http://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |