[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH 1/2] xen/compiler: Replace opencoded __attribute__((noreturn))
>>> On 25.11.13 at 11:25, Andrew Cooper <andrew.cooper3@xxxxxxxxxx> wrote: > --- a/xen/arch/arm/early_printk.c > +++ b/xen/arch/arm/early_printk.c > @@ -52,7 +52,7 @@ void __init early_printk(const char *fmt, ...) > va_end(args); > } > > -void __attribute__((noreturn)) __init > +void noreturn __init > early_panic(const char *fmt, ...) > { > va_list args; Here and elsewhere - these belong on the declaration of the function (and only there, or else there's pointless redundancy), not the definition (or else the compiler can't take proper action on the respective call sites). Only static functions not needing forward declarations would have the attribute on their definitions. Jan _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx http://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |