[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH v2] libxc: fix retrieval of and remove pointless check on gzip size
On Thu, 2013-10-31 at 10:22 +0000, Andrew Cooper wrote: > On 31/10/13 02:58, Matthew Daley wrote: > > Coverity-ID: 1055587 > > Coverity-ID: 1055963 > > Signed-off-by: Matthew Daley <mattjd@xxxxxxxxx> > > Reviewed-by: Andrew Cooper <andrew.cooper3@xxxxxxxxxx> I'd have used a few more ()s for clarity, but acked + applied. > > > --- > > v2: Cast to size_t instead of unsigned int, matching the type of > > unziplen. Suggested by Andrew Cooper. > > > > tools/libxc/xc_dom_core.c | 4 ++-- > > 1 file changed, 2 insertions(+), 2 deletions(-) > > > > diff --git a/tools/libxc/xc_dom_core.c b/tools/libxc/xc_dom_core.c > > index 0f367f6..3bf51ef 100644 > > --- a/tools/libxc/xc_dom_core.c > > +++ b/tools/libxc/xc_dom_core.c > > @@ -294,8 +294,8 @@ size_t xc_dom_check_gzip(xc_interface *xch, void *blob, > > size_t ziplen) > > return 0; > > > > gzlen = blob + ziplen - 4; > > - unziplen = gzlen[3] << 24 | gzlen[2] << 16 | gzlen[1] << 8 | gzlen[0]; > > - if ( (unziplen < 0) || (unziplen > XC_DOM_DECOMPRESS_MAX) ) > > + unziplen = (size_t)gzlen[3] << 24 | gzlen[2] << 16 | gzlen[1] << 8 | > > gzlen[0]; > > + if ( unziplen > XC_DOM_DECOMPRESS_MAX ) > > { > > xc_dom_printf > > (xch, > _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx http://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |